LhaForge

LhaForge Ver.1.6.7


LhaForgeについて

LhaForgeとは

LhaForgeは、ファイルを圧縮・解凍する無料のプログラムです。また、ファイルを分割・結合させることも出来ます。

さらに、「閲覧」機能を使えば、圧縮ファイルそのものは解凍せずに、含まれるファイルの一覧を見ることやその中から選択したファイルだけを解凍すること、あるいはファイルの追加や削除ができます。また、機能拡張スクリプトであるB2Eを使用することで対応形式を自由に増やすことが出来ます。

LhaForgeは統合アーカイバプロジェクトのDLLを利用しています。

業務利用について

LhaForge本体の利用に際しては作者の許可を取る必要はありません。しかし、問題が起きた際のサポートもありませんので、ご注意ください。また、LhaForgeが利用する統合アーカイバプロジェクトDLLには個別に利用条件があります。業務利用に際し、それら個別の利用条件の確認は利用者側で行ってください。

想定動作環境

Windows XP / Vista / 7 / 8 / 10 32bitおよび64bit版

一番確実に動作が保証できるのは、作者が主に使用しているWindows 10 Pro(64bit版)上です。

※LhaForge自体の動作環境です。統合アーカイバプロジェクトDLLの動作環境はこれとは異なる可能性があります。

※内部で使用している関数の都合上、Internet Explorer 4.0以上がインストールされている必要があります。動作確認済み環境では標準でインストールされています。

Windows MeやWindows 95/98、あるいは上記以外のバージョンのWindowsでも動くかもしれませんが、作者はそのような環境での確認ができていません。動作報告をいただければ幸いです。なお、Windows 98での動作保証はVer.1.3.0まで、Windows 2000での動作保証はVer.1.5.2までです。

開発環境

  • Windows 10 Pro/64bit 日本語版
  • Microsoft Visual Studio 2017 Community
  • WTL 9.1 Final


主な特徴

多様な対応形式

それぞれ必要なDLLをインストールすることにより、圧縮20形式および解凍34形式、完全性検査10形式をサポートします。また、別途XacRett.DLLを導入すれば、解凍可能な形式をさらに増やすことができます。

また、K.INABA氏作のアーカイバ「Noah」の拡張スクリプトである「B2E」が利用でき、対応形式を無制限に増やすことが出来ます。

標準対応形式

圧縮および解凍が可能な形式
LZH(LZS/LHA) / ZIP(JAR) / 7Z / CAB / TAR / GZ / BZ2 / LZMA / XZ / TGZ(TAR.GZ) / TBZ(TAR.BZ2) / TLZ(TAR.LZMA) / TXZ(TAR.XZ) / JAK / YZ1 / HKI / BZA / GZA / ISH / UUE
解凍が可能な形式
Z / TAZ(TAR.Z) / CPIO / A / LIB / RPM / DEB / ARJ / RAR / GCA / IMP / ACE / BEL / ISO
完全性検査が可能な形式
LZH / CAB / ZIP / 7Z / RAR / HKI / ARJ / ACE / IMP / ISO

DLLインストーラを装備

LhaForgeは外部の統合アーカイバDLLを用いてファイルの操作を行います。ですが、LhaForgeが使用するDLLはWindowsの初期設定ではインストールされていません。つまり、別途DLLを入手する必要があります。

LhaForgeではこの面倒な作業を自動化するために、DLLインストーラ(アップデータ)を添付しています。初回起動時に表示されるメッセージボックスや設定画面の「DLLの更新」からDLLインストーラを起動できます。このDLLインストーラを使えば、DLLの導入・更新が簡単に行えます。

また、DLLの更新を確認するよう定期的にメッセージを表示することができます。これにより、最新版のDLLを使用することができます。

注意点

XacRett.dllは自動取得・更新の対象ではありません。B2E32.dllはLhaForge本体にバンドルされています。

複数の使用方法を用意

LhaForgeでは

  1. エクスプローラ(シェル)の拡張を利用した右クリックメニュー経由
  2. デスクトップや「送る」メニューに作成したショートカット経由
  3. ファイルの関連付けを利用してファイルを一発解凍

の3つの使用方法があります。それぞれの使い方の詳細については、「使い方」の項目を参照してください。

必要に応じて詳細な設定が可能

LhaForgeでは各DLLの性能を最大限引き出せるように、出来るだけ詳細な設定ができるようにしてあります。もちろん、よく分からない場合には設定を変更する必要はありません。初期設定で十分実用に耐える設定になっています。

セキュリティを考慮

Directory Traversal問題

2004年7月末に「窓の杜」の記事「多くの解凍ソフトに指定外の場所へファイルが解凍されてしまう脆弱性が存在」で一般に知られるようになった「Directory Traversal問題」というものがあります。これは記事のタイトルの通り、予期しない場所にファイルを解凍できてしまうというものです。LhaForgeはこの問題に対し、以下に示す対策を行っています。

  • CAB / GCA / BZA / GZA / BEL / JAKの各形式については、危険なパス指定があれば解凍を拒否する
  • それ以外の形式についてはDLLに対策が施されているので、DLL側に対応を任せる

「UNICODE制御文字によるファイル名偽装」への対策

UNICODEの制御文字のうち、「見えない文字」や「文字方向を反転させる文字」はファイル名を偽装するために悪用されることがあります。LhaForgeではUNICODEが使用可能なUnlha32.dllおよび7-zip32.dllに対し、以下に示す対策を行っています。

  • Unlha32.dllはDLLに対策が施されているので、DLL側に対応を任せる
  • 7-zip32.dllはLhaForge側でファイル名をチェックし、危険な文字を検出したときは解凍を拒否する
  • アーカイブ内ファイル一覧では名前に危険な文字が含まれるファイルは赤く表示し注意を促す

「バイナリ植え付け」への対策

Windowsでは、一般にカレントディレクトリ(現在作業中の場所)が外部DLLファイル検索対象に入っています。このため、対策がない場合、外部DLLロード時に、カレントディレクトリに置いた悪意あるプログラムをロードさせられる可能性があります。

LhaForgeでは、DLLロード時、カレントディレクトリを一時的にLhaForge本体の場所に変更する対策を行っています。

なお、LhaForgeで行った対策は必ずしも万全とは限りません。出来る限り危険と思われるファイルは解凍しないようにしてください。

※なお、上の文章で単にDLLと表記した場合、「統合アーカイバプロジェクト」のアーカイバDLLを指しています。


LhaForgeの情報

利用条件

LhaForge Ver.1.6.7は修正BSDライセンスで提供されています。利用者はこのライセンスに基づいて使用・再配布・改変を行うことができます。

ソフト紹介などでのスクリーンショットの公開には特に条件は設けません。業務利用については、「LhaForgeとは」の「業務利用について」を参照してください。

B2Eスクリプトエンジン(B2E32.dll)とDLLインストーラ(LFCaldix.exe)には単体ではNYSL ver 0.9982が適用されていますが、LhaForgeと一緒に配布する場合には修正BSDライセンスを適用します。

以下が修正BSDライセンスの参考日本語訳です。

LhaForge Ver.1.6.7

Copyright (c) 2005-2019, Claybird All rights reserved.

ソースコード形式かバイナリ形式か、変更するかしないかを問わず、以下の条件を満たす場合に限り、再頒布および使用が許可されます。

  • ソースコードを再頒布する場合、上記の著作権表示、本条件一覧、および下記免責条項を含めること。
  • バイナリ形式で再頒布する場合、頒布物に付属のドキュメント等の資料に、上記の著作権表示、本条件一覧、および下記免責条項を含めること。
  • 書面による特別の許可なしに、本ソフトウェアから派生した製品の宣伝または販売促進に、Claybirdの名前またはコントリビューターの名前を使用してはならない。

本ソフトウェアは、著作権者およびコントリビューターによって「現状のまま」提供されており、明示黙示を問わず、商業的な使用可能性、および特定の目的に対する適合性に関する暗黙の保証も含め、またそれに限定されない、いかなる保証もありません。著作権者もコントリビューターも、事由のいかんを問わず、損害発生の原因いかんを問わず、かつ責任の根拠が契約であるか厳格責任であるか（過失その他の）不法行為であるかを問わず、仮にそのような損害が発生する可能性を知らされていたとしても、本ソフトウェアの使用によって発生した（代替品または代用サービスの調達、使用の喪失、データの喪失、利益の喪失、業務の中断も含め、またそれに限定されない）直接損害、間接損害、偶発的な損害、特別損害、懲罰的損害、または結果損害について、一切責任を負わないものとします。

注意事項

LhaForgeが使用する統合アーカイバプロジェクトのDLLは、それぞれについて著作権所有者が存在します。また、それぞれのファイルについて転載条件や使用条件等が存在する可能性があります。詳細については、それぞれのDLLに付属の文章をお読みの上、それらを遵守してください。

LhaForgeを使用して起きた不具合、疑問等ございましたら作者までご連絡ください。出来る範囲で対処させていただきます。

LhaForgeに含まれるファイルの情報

右クリック拡張モジュールはHIROさん(JJworkshop)のTfShellをベースにして開発させていただきました。

DLLインストーラ(LFCaldix)はK.INABAさん(kMonos.net)のcaldixを改変して開発させていただきました。

B2E32.dllはK.INABAさん(kMonos.net)のNoah 3.195を改変して開発させていただきました。

インストーラ/アンインストーラにはEXEpress CX5 for free software License Editionを利用させていただきました。

LhaForge Ver.1.6.0の作成にあたり、rain(Amate)さんによる修正を取り込ませていただきました。


DLLと形式

LhaForgeで対応しているアーカイバDLLと、その対応形式の一覧です。LhaForgeではある程度以上古いDLLは使用できません。

UNLHA32.DLL

LZH(LZS/LHA)

  • 圧縮
  • 解凍
  • 閲覧
  • 自己解凍ファイル作成

7-ZIP32.DLL

ZIP(JAR)

  • 圧縮
  • 解凍
  • 閲覧
  • 自己解凍ファイル作成
  • パスワード付き圧縮
  • パスワード付き自己解凍ファイル作成
  • 分割圧縮
  • パスワード付き分割圧縮

※1.ZIPの自己解凍ファイル作成にはsfx32gui.datが必要(DLLインストーラで導入できます)

※2.BZip2方式を使用した場合、ZIPの自己解凍ファイルを作成することはできません。

7Z

  • 圧縮
  • 解凍
  • 閲覧
  • 自己解凍ファイル作成
  • パスワード付き圧縮
  • 分割圧縮
  • パスワード付き分割圧縮

※BZip2方式を使用した場合7Zの自己解凍ファイルを作成することはできません。

CAB32.DLL

CAB

  • 圧縮
  • 解凍
  • 閲覧
  • 自己解凍ファイル作成

Jack32.dll

JAK

  • 分割
  • 結合
  • 自己結合ファイル作成

※LhaForgeでは分割を圧縮、結合を解凍と表記

YZ1.DLL

YZ1

  • 圧縮
  • 解凍
  • 閲覧
  • 自己解凍ファイル作成
  • パスワード付き圧縮
  • パスワード付き自己解凍ファイル作成
  • 公開鍵方式パスワード付き圧縮
  • 公開鍵方式パスワード付き自己解凍ファイル作成

TAR32.DLL

TAR

  • 圧縮
  • 解凍
  • 閲覧

GZ

  • 圧縮
  • 解凍
  • 閲覧

BZ

  • 圧縮
  • 解凍
  • 閲覧

LZMA

  • 圧縮
  • 解凍
  • 閲覧

XZ

  • 圧縮
  • 解凍
  • 閲覧

TGZ(TAR.GZ)

  • 圧縮
  • 解凍
  • 閲覧

TBZ(TAR.BZ2)

  • 圧縮
  • 解凍
  • 閲覧

TLZ(TAR.LZMA)

  • 圧縮
  • 解凍
  • 閲覧

TXZ(TAR.XZ)

  • 圧縮
  • 解凍
  • 閲覧

Z/TAZ/CPIO/A/LIB/RPM/DEB

  • 解凍
  • 閲覧

UNARJ32J.DLL

ARJ

  • 解凍
  • 閲覧

unrar32.dll

RAR

  • 解凍
  • 閲覧

UnGCA32.DLL

GCA

  • 解凍
  • 閲覧

UnImp32.dll

IMP

  • 解凍
  • 閲覧

UnAceV2J.DLL

ACE

  • 解凍
  • 閲覧

UnHki32.dll

HKI

  • 圧縮
  • 解凍
  • 閲覧
  • パスワード付き圧縮
  • 自己解凍ファイル作成

Bga32.dll

BZA

  • 圧縮
  • 解凍
  • 閲覧
  • 自己解凍ファイル作成

GZA

  • 圧縮
  • 解凍
  • 閲覧
  • 自己解凍ファイル作成

AISH32.DLL

ISH

  • 変換
  • 復元

uuencode

  • 変換
  • 復元

※1.LhaForgeでは変換を圧縮、復元を解凍と表記

※2.拡張子が.ish/.txt/.log/.uue/.docの場合のみAISH32.DLLでの解凍を試みます

Unbel32.dll

BEL

  • 解凍のみ

※拡張子が.belの場合のみUnbel32.dllでの解凍を試みます

UnIso32.dll

ISO

  • 解凍
  • 閲覧

XacRett.DLL

対応形式多数

  • 解凍
  • 閲覧

※ユーザーが使用を指示した場合のみ使用します

B2E32.DLL

別途処理プログラムとB2Eスクリプトファイルにより対応形式を拡張可能です。

  • 圧縮
  • 解凍
  • 閲覧

※ユーザーが使用を指示した場合のみ使用します


Ver.1.6.6からVer.1.6.7への主な変更点

  • 不具合修正

開発履歴

特に表記がない物はLhaForge本体の変更

Beta20190429からVer.1.6.7へ

  • 正式版として公開

Ver.1.6.6からBeta20190429へ

  • ファイル一覧のカラム幅が保存されていなかった問題を修正
  • 圧縮後削除が失敗することがあった問題を修正
  • 開発環境をVS2013に更新

Ver.1.6.5からVer.1.6.6へ

LhaForge本体

  • unrar32.dll使用時、レスポンスファイルがUTF8になっていなかったために解凍できないファイルがあった問題を修正
  • ファイル一覧ウィンドウ:ファイル情報をコピーできるようにした

LFCaldix

  • 最新のUnlha32.dllのインストールに対応

Beta20141220からVer.1.6.5へ

  • 正式版として公開

Beta20141019からBeta20141220へ

  • 7zで/levelオプションに効果が無かった問題を修正

Ver.1.6.4からBeta20141019へ

  • ZIP/7zでの分割圧縮にデフォルト分割サイズの設定を追加
  • ZIP/7z/JAKで分割圧縮時のサイズ指定コマンドラインを追加(/volume:<サイズ>)
  • 設定で一時フォルダの指定項目を追加

Beta20140915からVer.1.6.4へ

  • 正式版として公開

Ver.1.6.3からBeta20140915へ

  • ファイル一覧ウィンドウ:関連づけで開く際、パスワード入力をキャンセルすると0バイトのファイルが開かれる問題を修正
  • ファイル一覧ウィンドウ:カラム表示/非表示の設定が正常に動作しない問題を修正

Beta20140712からVer.1.6.3

  • ファイル一覧ウィンドウ:格納パスの表示設定を変更したとき新旧設定の表示形式が混在することがある問題を修正
  • ファイル一覧ウィンドウ:ソート時の第2キーを格納パスにした

Beta20140615からBeta20140712

  • ファイル一覧ウィンドウ:「格納パス」に、ファイル名を表示しない設定を追加
  • ファイル一覧ウィンドウ:「元サイズ」が右揃えになっていない問題を修正
  • 7z自己解凍ファイルの作成にて、本来対応しているはずの形式が非対応形式とされてしまうことがある問題を修正

Ver.1.6.2からBeta20140615

  • ファイル一覧ウィンドウ:パスワード付きアーカイブの閲覧時はタイトルバーに「パスワード保護*」と表示するようにした
  • ファイル一覧ウィンドウ:パスワード付きZIP/7zアーカイブへのファイル追加にはパスワードを要求するようにした
  • ファイル一覧ウィンドウ:タブ切り替え時にカラムの幅がデフォルト値に戻ってしまう問題を修正
  • ファイル一覧ウィンドウ:前回の表示モードとカラムの幅が起動時に復元されていなかった問題を修正
  • ファイル一覧ウィンドウ:パスワード付きアーカイブに格納されたファイルの属性が不明扱い("???"と表示)になっていた問題を修正
  • 右クリックメニュー:「常に発展メニューを表示する」を有効にしているとメニューの有効/無効が正常に更新されない問題を修正

Beta20130402からVer.1.6.2へ

  • 正式版に格上げ

Ver.1.6.1からBeta20130402へ

  • 右クリックで発展メニューを使用した場合、圧縮形式が正しく選択できないことがあった問題を修正
  • 「圧縮メニューのカスタマイズを有効に」のチェックボックスをデフォルトで有効にした
  • 圧縮/解凍の際、書き込み不可能なディレクトリを作業ディレクトリにしていた問題を修正
  • 拡張子の前に半角スペースがある書庫の解凍時にフォルダ作成に失敗する問題を修正
  • 「解凍しない拡張子」のスペルミスを修正
  • UTF-8対応版unrar32.dllを使用できるようにした

Beta20120930からVer.1.6.1へ

  • 正式版に格上げ
  • このバージョン以降は、基本的にバグ修正のみとし、機能追加は行わない方針です。

Beta20120909からBeta20120930へ

LhaForge本体

  • ファイル一覧ウィンドウ:大きなファイルサイズがマイナスで表記されていた問題を修正
  • ファイル一覧ウィンドウ:ファイルサイズをバイト単位で表記する際、3桁区切りで表示するようした
  • ファイル一覧ウィンドウ:読み取り専用ファイルに対する追加/削除操作を無効にした
  • ファイル一覧ウィンドウ:追加ができないファイルに対してドラッグ&ドロップを行うと、投入されたファイルを一覧表示しようとする問題を修正
  • B2E32.dllをXacRett.DLLより優先させても、XacRett.DLLが優先して使われる問題を修正

B2E32.dll(Ver.0.07 Beta2からVer.0.07 Beta3へ)

  • ショートファイル名が取得できないファイルを扱うと、バッファオーバーフローが起きることがあった問題を修正

Beta20120723からBeta20120909へ

  • ファイル一覧ウィンドウ:関連付けでフォルダを開くとき、フォルダ内部のファイルが展開されないことがあった問題を修正

Beta20120614からBeta20120723へ

  • ファイル一覧ウィンドウ:タブが無効の時に複数のファイルを開こうとすると処理が終わらなくなることがある問題を修正
  • ファイル一覧ウィンドウ:閲覧中の一つ、もしくは全部のアーカイブを解凍後、アーカイブを閉じるコマンドを追加
  • 圧縮後のファイル削除設定が有効なとき、削除確認ダイアログに表示するファイル名の個数に上限を設定した

Beta20120418からBeta20120614へ

  • ファイル一覧ウィンドウ:フォルダに対して「関連付けで開く」が無効になっていたバグを修正
  • ファイル一覧ウィンドウ:デフォルトでファイル一覧をソートするようにした
  • ファイル一覧ウィンドウ:メニューからもソート設定を行えるようにした
  • ファイル一覧ウィンドウ:ツリービューにコンテキストメニューを追加
  • ファイル一覧ウィンドウ:ツリービューの表示/非表示を追加
  • ファイル一覧ウィンドウ:ツールバーの表示/非表示設定を追加
  • ファイル一覧ウィンドウ:ツールバー画像の変更に対応を追加
  • gzipのデフォルト圧縮レベルを9に変更
  • tar圧縮時に拡張子およびパスによるソートを行う設定を追加

Beta20120416からBeta20120418へ

LhaForge本体

  • 指定されたパスが相対パスの場合、正しくパス検索が行われないことがあった問題を修正

LFCaldix本体

  • 指定されたパスが相対パスの場合、正しくパス検索が行われないことがあった問題を修正

B2E32.dll(Ver.0.07 BetaからVer.0.07 Beta2へ)

  • バイナリ植え付け問題対策のため、DLLロード処理/実行ファイル検索処理を修正
  • コメントのためにcomment関数を追加

Ver.1.6.0からBeta20120416へ

LhaForge本体

  • 一括展開時、ヘッダ暗号化7zファイルを展開できない問題を修正
  • LFCaldixに相対パスが指定された場合にも正しくパスを認識するようにした
  • 圧縮/解凍のログが全面に表示されるようにした
  • LhaForge設定のB2E32.dllの項目にて、利用可能なB2Eスクリプト一覧を表示するようにした
  • Office 2007以降のドキュメントファイル(docx等)やOpenDocument Formatファイル(.odt等)を解凍対象からデフォルトで外した(変更可能)
  • B2E32.dllを使用した追加圧縮/削除に対応

LFCaldix

  • 環境変数(OSのものおよびLhaForge仕様のもの)を使用できるようにした

B2E32.dll(Ver.0.06からVer.0.07 Betaへ)

  • 開発環境をVisual C++ 2005に移行
  • 圧縮時、ファイル名にワイルドカードを指定できるようにした
  • add: / delete: セクションを追加
  • mod_scan / mod_xscan を追加
  • arc関数に引数を追加

Beta20110402からVer.1.6.0へ

  • ファイル一覧ウィンドウからアーカイブ検査を行えるようにした
  • 各DLLに渡すパラメータを調整

Beta20110223からBeta20110402へ

  • 設定画面でツリービュー項目を切り替えた際の画面のちらつきを解消(rain(Amate)氏のパッチによる)

Beta20101205からBeta20110223へ

LhaForge本体

  • アーカイブ名に空白文字が2文字以上連続して含まれている場合、空白が1文字までに短縮されたフォルダ内に展開されてしまう問題を修正
  • CAB形式ファイルのうち、DTV問題を起こすファイルに対する代替展開機能を削除し、展開を拒否するように修正
  • PPMdメソッドを用いたZIP圧縮設定に対応
  • AESによるZIP暗号化設定に対応
  • LZMA2メソッドを用いた7z圧縮設定対応
  • tar32.dllの要求バージョンを2.36に更新
  • 7-Zip32.dllの要求バージョンを9.20に更新

LFCaldix

  • 7zアーカイブ展開機能追加
  • UnIso32.dllの自動取得に対応

Beta20101020からBeta20101205へ

LhaForge本体

  • TAR32.DLLの新形式、.xz/.lzma/.txz(tar.xz)/.tlz(tar.lzma)に対応
  • プロセス優先度設定を追加
  • プロセス優先度設定コマンドラインを追加(/priority:{lower,low,normal,higher,high})
  • /cfgオプションに環境変数を使用できるように
  • 「開く動作」設定が正しく反映されない問題を修正

LFCaldix

  • DLL読み込み時の脆弱性の修正(Caldix 1.21相当に更新)

その他のファイル

  • TAR32.DLLの新形式、.xz/.lzma/.txz(tar.xz)/.tlz(tar.lzma)に対応

Ver.1.5.2からBeta20101020へ

LhaForge本体

  • ZIPのLZMA方式での圧縮に対応
  • ZIP圧縮時、ファイル名文字コードにUTF-8の使用を強制する設定を追加
  • 7-Zip32.dllの要求バージョンを4.65に更新
  • 「正常に圧縮されたファイルを削除」と「可能ならフォルダより下のファイルを圧縮」を同時に指定した場合、フォルダ内のファイルのみが削除されていた問題を修正
  • ユーザー操作無しでのDLL全自動インストール/アップデート設定追加
  • 出力先フォルダを毎回尋ねるコマンドラインオプション"/oa"を追加
  • "/delete"オプションを解凍時にも適用可能に
  • バージョン管理ツール用にバージョン情報を詳細に記載
  • "/cfg"オプションによる設定ファイル指定が機能していなかった問題を修正
  • 個別圧縮時、出力先を尋ねるダイアログで同じディレクトリを使用する設定が機能していなかった問題を修正

LFCaldix

  • 全自動インストールオプション(/silent)追加
  • zlibを1.2.5に更新

Ver.1.5.1からVer.1.5.2へ

  • カレントディレクトリからはDLLをロードしないように(バイナリの植え付けへの対応)
  • 7-Zip32.dllの要求バージョンを最新に

Beta20100726からVer.1.5.1へ

  • 正式版としてコンパイル

Beta20100711からBeta20100726へ

LhaForge.exeのみの更新

  • 圧縮形式選択ダイアログにて「正常に圧縮されたファイルを削除」の有効/無効を選択可能に
  • コマンドラインオプション追加

Beta20100618からBeta20100711へ

LFCaldixのみの更新

  • UNACEV2J.DLLを使用中に実行すると、UNACEV2.DLLが更新されない問題を修正
  • ドキュメント内のURLを修正
  • アイコンをオリジナルCaldixに近い物に変更

Beta20100603からBeta20100618へ

  • 親フォルダを無視して中のファイルだけを圧縮する設定およびコマンドラインを追加

Ver.1.5.0からBeta20100603へ

  • ファイル一覧ウィンドウのソート設定・ツリー展開などが動作しない問題を修正
  • ファイル一覧ウィンドウにて、一文字だけのディレクトリ名が無視される問題を修正
  • Windows 7上で実行した際、ファイル一覧ウィンドウのツリービューのフォルダアイコンがドライブアイコンになっていた問題を修正
  • ファイル名も暗号化されたRAR書庫の展開時、パスワード要求回数を減らした
  • 「パスワード入力回数を最小限にする」を実装
  • 解凍されたファイルがすぐにはエクスプローラ上に表示されない環境のために、「処理完了をシェルに通知する」オプションを追加
  • 設定ウィンドウの位置を画面中央にした
  • 「正常に圧縮されたファイルを削除」を実装
  • コマンドラインオプションを追加

Beta20100307からVer.1.5.0へ

  • 正式版としてコンパイル

Beta20100221からBeta20100307へ

LhaForge本体

  • 無効化したDLLを用いて圧縮操作を行うと異常終了する問題を修正
  • LhaForgeの設定画面からメニューカスタマイズを行うと、カスタマイズ設定が保存されない問題を修正

右クリックメニュー

  • エクスプローラのメニューにLhaForgeのメニューが複数登録されてしまう問題を修正

アンインストーラ

  • .isoの関連付け解除を実装

Beta20091214からBeta20100221へ

  • ファイル一覧ウィンドウに「アーカイブを開く」ボタンを追加
  • TAR32.DLLの文字コード変換制御に対応

Beta20091115からBeta20091214へ

LhaForge本体 - ファイル一覧ウィンドウ

  • 環境変数%PATHEXT%を参照し、実行可能形式は全て開かないようにする設定を追加
  • ツールバー・メニューを更新
  • タブをCtrl+Wで閉じられるようにした
  • タブの閉じるボタンを廃止
  • 常にタブを同じウィンドウで開く設定を追加
  • エクスプローラの「送る」に登録されたショートカットを利用できるようにした
  • 「プログラムで開く」に登録するコマンドに環境変数が使用できるようにした
  • ソートしているカラムが分かりやすいようにアイコンをつけた
  • 7-Zip32.dll使用時、ディレクトリが削除できないことがあった問題を修正

LhaForge本体 - その他

  • 圧縮時、出力先を元のファイルと同じディレクトリにしていると処理に失敗する問題を修正
  • 処理の結果一覧で、解凍時のログウィンドウのタイトルが「検査」で表示される問題を修正
  • 圧縮時、コマンドラインで圧縮メソッドと圧縮レベルを指定できるようにした
  • 解凍/検査時に処理をスキップする拡張子の設定を追加
  • 毎回出力先を指定する設定で、一度に連続して圧縮/解凍するときは、前回使用したディレクトリを使用するようにした
  • 各DLLを無効化する設定を追加
  • .isoの関連付け設定を追加
  • 関連付けの設定で、.iso/.jar/.lib/.aはデフォルトでは関連付けしないようにした
  • 64ビット版Windowsでの右クリックメニュー判定が間違っていた問題を修正

右クリックメニュー

  • ソースコードを整理
  • B2Eメニューとユーザーが追加したコマンドが競合することがあった問題を修正

Beta20091003からBeta20091115へ

  • ファイル一覧ウィンドウをタブ化した
  • ファイル一覧ウィンドウのアーカイブ構造解析のダイアログに処理中のファイル名も表示するようにした
  • ファイル一覧ウィンドウのアーカイブ構造解析を中断できるようにした
  • ファイル一覧モードで起動されたとき、表示対象のファイルが無い場合は空ウィンドウを開くようにした
  • 設定ファイルの読み込み・書き込みをAPIではなく自前のコードで行うようにした
  • 記録できる文字の種類を増やすため、設定ファイルをUTF-16LEで記録するようにした
  • Ver.1.0.1以前で設定ファイルに記録されたパスワードについて、削除確認をやめ、強制的に削除するようにした
  • Beta20091003でTAR32.DLLを用いたファイル展開が失敗するようになっていた問題を修正

Beta20090320からBeta20091003へ

  • 「フォルダ名末尾の数字と記号を取り除く」が有効な場合、記号/数字のみからなるファイル名の書庫の解凍ができなかった問題を修正
  • 圧縮・解凍のフォルダ指定が無視される問題を修正
  • 関連付け判定が厳しすぎたため、必要以上に関連付け設定を行う事があった問題を修正
  • B2E32.dll使用時、書庫に余計な拡張子.archiveが付与されることがあった問題を修正
  • ファイル一覧ウィンドウのコードを大幅に書き直し
  • ファイル一覧ウィンドウでの検索結果でソートを利用可能にした
  • ファイル一覧ウィンドウで、ツリービューへのドラッグ&ドロップでの圧縮を行えるようにした
  • unrar32.dllの更新に対応
  • TAR32.DLLの更新に対応
  • UnIso32.dllに対応(関連付けは未実装)

Beta20080318からBeta20090320へ

  • 解凍時、フォルダ名末尾の数字と記号を取り除く設定で、末尾に空白文字が現れた場合処理に失敗することがあった問題を修正
  • 解凍時、ネットワーク上などに展開する場合、「フォルダ名末尾の数字と記号を取り除く」が効かないことがあった問題を修正
  • 「出力先を開くファイラ」の設定で、参照できる情報を増やした(環境変数や出力先の情報など)
  • ドライブを丸ごと圧縮する時は、ドライブのボリュームラベルを仮ファイル名とするようにした
  • DLLの優先使用設定やファイル一覧ウィンドウの「関連づけで開く」の拡張子リストは、"."が抜けていても正しく処理できるようにした
  • 設定ダイアログの文面の調整

Ver.1.4.1からBeta20080318へ

  • UnlhaFindFirstW()に渡すファイル検索パラメータを変更

Ver.1.4.0からVer.1.4.1へ

  • 7-Zip32.dll使用時、追加圧縮の時だけファイル名の文字コードを変換し忘れていた問題を修正
  • ファイル追加圧縮時のUNICODE対応/非対応の判定を逆にしていた問題を修正

Beta20071222からVer.1.4.0へ

  • B2E32.dllの要求バージョンをVer.0.05に引き上げ

Beta20071128からBeta20071222へ

  • 圧縮の出力先が元のファイルと同じ場所の設定の時に「B2Eで圧縮」が失敗する問題を修正
  • アーカイバDLLの要求バージョンを現在の最新版に引き上げ
  • デフォルトの関連付けアイコンのファイル名LF_icons_v1_4.dllに変更

Beta20071111からBeta20071128へ

ShellExtDLL.dll

  • シェル拡張DLLが32bit/64bitの両方で同じレジストリキーを参照していた問題を修正

Beta20071104からBeta20071111へ

  • 64bit Windows用シェル拡張のShellExtDLL64.dllを追加
  • 64bit Windows用設定補助ツールのLFAssist64.exeを追加
  • LhaForgeのシェル拡張の設定が64bit Windowsでも正しく反映されるようにした

Beta20071022-2からBeta20071104へ

LhaForge.exe

  • B2Eの圧縮形式/メソッドを右クリック/ドラッグ拡張メニュー中に展開できるようにした
  • Windows Vistaで、必要がある場合に設定ダイアログのOKボタンにシールドアイコンを表示するようにした

ShellExtDLL.dll

  • B2Eの圧縮形式/メソッドを右クリック/ドラッグ拡張メニュー中に展開できるようにした
  • 内部動作をUNICODE化した
  • エクスプローラのメニュー中に「LhaForgeで操作」メニューが追加されることがあった問題を修正

MenuEditor.exe

  • マニフェストが正しく適用されていなかったため、Virtual Storeのリダイレクトの影響を受けることがあった問題を修正

Beta20071022からBeta20071022-2へ

  • 「解凍の出力先」が「圧縮の出力先」に間違って読み込まれてしまう問題を修正

Beta20070914からBeta20071022へ

  • プログラム中のメニューやダイアログの表記を一部修正
  • 7zのマルチスレッドモードの設定を削除(7-Zip32.dll側のデフォルト設定でONになっている)
  • LZH/ZIP/7z/BZA/GZA形式書庫に対するファイル追加に対応(同名ファイルは確認なしで上書きされます)
  • ファイル一覧モードからの一部ファイル解凍をZIP/7z形式に対して高速化
  • ディレクトリ階層を無視したファイル一覧モードでもファイルを関連付けで開けるようにした
  • ドライブルートにファイルを解凍しようとしたとき、失敗することがあった問題を修正
  • 半角空白もしくは.で終わる名前を含むフォルダを作成しないようにした
  • 複数のファイルを個別圧縮/展開/検査しているときは、プログレスバーを表示するようにした
  • 解凍時、出力先を毎回指定する設定でデフォルト選択先を元ファイルと同じ場所にした
  • 関連付けのアイコン選択ダイアログで、アイコンに含まれる透過色が正しく表示されていないことがあった問題を修正
  • Windows VistaのUACに対応するため、関連付けとシェル拡張を別アプリ(LFAssist.exe)で行うようにした(シールドアイコンの設定は未実装)
  • 開発ツールの都合で実行ファイルのアイコンから256x256のイメージを削除

Beta20070813からBeta20070914へ

LhaForge.exeのみ更新

  • UNICODE対応(Unlha32.dll/7-Zip32.dll使用時のみ)
  • ワイルドカードの展開がうまくいっていなかった問題を修正
  • 一部形式で展開に失敗するようになってしまっていたのを修正
  • アイコン選択ダイアログから旧形式のアイコンを選択するためのボタンを削除
  • レスポンスファイルの読み取りを、UNICODEとSJISの両方から行えるようにした(文字コードはコマンドラインで明示的に指定する。デフォルトはShiftJIS)
  • レスポンスファイルの文字コード指定のための「/cp:<文字コード名>」オプションを追加
  • ファイルに含まれるUNICODE制御文字を不正として扱うようにした(ファイル一覧画面上では赤字表示)
  • ファイル一覧での実行禁止拡張子のデフォルト拡張子を追加
  • 要求DLLバージョンを引き上げた
  • LZH形式のSFX作成を二段階ではなく一度で行うようにした
  • ファイル一覧で「ディレクトリを上がる」ショートカットにAlt+↑を追加
  • AISH32.dll/Jack32.dll/XacRett.dll/B2E32.dll使用時も解凍後ファイル削除を警告メッセージなしで行えるようにした
  • RAR分割書庫の正常解凍後、分割書庫全体を削除するオプションを追加
  • ファイル一覧画面でのディレクトリ構造解析を改善
  • デフォルト圧縮形式を指定できるようにした(「お手軽ショートカット」での圧縮形式指定を省略できます)

Ver.1.3.0からBeta20070813へ

LhaForge.exe

  • 開発環境を VC2005 / WTL8.0Final / STLport5.1.2 に移行
  • 対応していない形式のファイル一覧を表示した後、設定画面を開くと異常終了する問題を修正
  • 複数ファイルの解凍時、出力フォルダを相対パスで指定すると正しくないフォルダに展開される問題を修正
  • Escキーでファイル一覧ウィンドウを閉じるオプションを追加
  • コマンドライン引数に与えられたファイル名のワイルドカードを展開するようにした
  • ファイルの解凍・完全性検査のログをリスト表示するようにした
  • 使用する設定ファイルをコマンドラインから指定できるようにした
  • Vistaに仮対応
  • デフォルトでユーザープロファイルフォルダを使用するように変更

LFCaldix.exe

  • Vistaでは起動に管理者権限を要求するようにした
  • デフォルトでユーザープロファイルフォルダを使用するように変更

ShellExtDLL.dll

  • デフォルトでユーザープロファイルフォルダを使用するように変更
  • メニュー項目の「7z分割」だけ'z'が大文字だったのを修正

Beta20070402からVer.1.3.0へ

  • ユーザー間共通設定を追加
  • LF_Icons.dll(旧仕様)を削除

Beta20070401-2からBeta20070402へ

  • 関連付けアイコンの並び順の仕様を拡張
  • B2E32.dllを使用した圧縮での形式選択のドロップダウンを大きくした

Beta20070401からBeta20070401-2へ

ShellExtDLL.dll

  • Windows XPでユーザー定義メニューなどが表示されない問題を解決
  • エクスプローラのファイルメニューを何度も出し入れすると大量にメニューが追加されてしまう問題を解決

Beta20070317からBeta20070401へ

LhaForge.exe

  • ファイル一覧時、「全てのファイルを表示」(フォルダを含まない全てのファイル一覧)をできるようにした
  • ファイル一覧時のデフォルト拒否拡張子を追加
  • B2Eを優先する拡張子を設定できるようにした
  • 解凍・閲覧・検査の対象にフォルダを指定した時は、フォルダ内の対応形式のファイルを処理するようにした
  • F6/F7/F8でファイル一覧モード切替
  • 関連付けで開く時、Shiftキーを押している時と通常時で動作を解凍・閲覧・検査からそれぞれ選択できるようにした
  • ファイル一覧時、「関連づけで開く」で開けないファイルがあった問題を修正
  • ファイル一覧時、「プログラムから開く」メニューを追加
  • 出力先を毎回選択する設定で解凍する時、「以降も同じフォルダに解凍する」を選択できるようにした
  • ファイル一覧時のファイル検索に対応
  • ファイル一覧時、フォルダのサイズをフォルダ内ファイルのサイズの合計にするようにした
  • ファイル一覧ウィンドウに「アーカイブを開く」メニューを追加
  • 関連付け設定のアイコン設定ダイアログでアイコンファイルとして参照できるファイル種類を追加
  • 設定ダイアログをサイズ変更可能にした

ShellExtDLL.dll/MenuEditor.exe

  • 右クリックメニューからドライブを圧縮出来なかった問題を修正
  • ユーザー定義メニューを追加可能にした
  • B2E関連メニューの追加
  • 大量のファイルも右クリックメニューからなら処理できるようにした
  • カスタマイズメニューのデフォルト項目をLhaForgeの標準と合わせた

その他

  • 添付のB2E32.dllをVer.0.04正式版に更新

Ver.1.2.0からBeta20070317へ

  • ファイル一覧画面で圧縮形式やCRC、圧縮率などの表示を出来るようにした
  • B2E32.dllを使用した圧縮/解凍/ファイル一覧に対応
  • LhaForgeのコマンドラインでレスポンスファイルを指定できるようにした
  • C:直下など、ドライブルートのファイルを閲覧するとツリービューのフォルダアイコンがドライブのアイコンになる問題を修正
  • B2E対応のために二重フォルダ判定を強化
  • LFCaldixのDLLインストール先からもアーカイバDLLを探すようにした
  • メールアドレス表記変更
  • コマンドラインスイッチ追加

Beta 20061128からVer.1.2.0へ

  • 正式版としてコンパイル

Beta 20061016からBeta 20061128へ

LhaForge.exe

  • 階層無視のファイル一覧表示でファイル名項目に表示する情報を、パスを削除しファイル名のみにした
  • 「表示項目のカスタマイズ」メニューを追加
  • ファイル一覧時、右クリックメニューなどから一度に複数ファイルを閲覧すると「XacRett.dllを使用する」設定が無視されることがあった問題を修正
  • JAKファイル解凍時の脆弱性対策および上書き確認機能を追加
  • シェル拡張メニューをサブメニュー以下に放り込む設定を追加
  • 関連付けのアイコン選択ダイアログをサイズ変更可能にした
  • 外部アイコンファイルを使い、一括して関連付けのアイコンを設定出来るようにした(ただし順番の関係で、LF_Icons_v1_1.DLLだけが正常動作の対象)

ShellExtDLL.dll

  • 右クリック/右ドラッグメニューをサブメニュー以下にまとめる設定を追加

Beta 20061010からBeta 20061016へ

ShellExtDLL.dll

  • Windows XPで一部のメニューが表示できない問題を解決するため、メニューの構成を変更

MenuEditor.exe

  • ダイアログにアイコンが設定されていなかったのを修正

Beta 20060827からBeta 20061010へ

LhaForge.exe

  • "."を名前に含むフォルダを圧縮する場合、"."以降も出力ファイル名に含むよう修正
  • UNHKI32.DLL使用時の書庫検査を改善
  • ドライブを丸ごと圧縮する時は出力ファイル名の入力を求めるように修正
  • ファイル一覧ウィンドウに「すべて解凍」ボタンを追加
  • 正常解凍後、確認ダイアログを出さずにゴミ箱に移動/削除する設定を追加(AISH32.dll/Jack32.dll/XacRett.dll使用時を除く)
  • 「XacRett.DLLを優先する拡張子」にワイルドカードを使えるようにした
  • ファイル一覧ウィンドウでのカラムの並べ替え・項目選択に対応
  • 一部の設定ダイアログが乱れていたのを修正
  • ファイル一覧ウィンドウから「関連付けで開く」「一時フォルダに展開」を追加
  • ファイル一覧ウィンドウの右クリックメニューに「アーカイブのフォルダに解凍」を追加
  • ファイル一覧ウィンドウでフォルダのサイズにサブアイテムのファイルサイズの合計を設定するよう変更
  • ファイル一覧ウィンドウのドラッグ&ドロップ解凍で渡すファイル名を修正

ShellExtDLL.dll

  • 「検査」メニュー追加
  • 右クリックメニューのカスタマイズに対応

MenuEditor.exe

今バージョンから登場した、右クリックメニューのカスタマイズ用ツール。

Beta 20060731からBeta 20060827へ

  • Shift+クリックでファイル一覧ウィンドウを開いたときにウィンドウがアクティブになるよう修正
  • ファイル閲覧ウィンドウから「選択を解凍」したときに、解凍先がデスクトップ決め打ちになってしまっていたのを「解凍共通設定」の出力先に合わせるように修正
  • 関連付けの設定が壊れていた場合、自動で修復するようにした
  • 関連付けで圧縮ファイルを開いたときの動作を閲覧と解凍から選べるようにした
  • 書庫閲覧で、階層を無視した一覧表示を実装
  • 個別圧縮を実装(CTRLを押しながら圧縮/専用のショートカットから/圧縮形式選択ダイアログから操作)
  • 書庫テストを実装
  • ファイル一覧ウィンドウの位置を保存する設定を追加
  • アーカイブ操作ログのバッファのサイズを64KBから256KBへ拡張
  • アーカイブ操作ログの表示ダイアログをサイズ変更可能にした

※今回のバージョンから関連付けのコマンドラインオプションが変更になります。Beta20060827を使ったあとでVer.1.1.0/Beta20060731以前に戻す場合には、古い方のLhaForgeで一旦関連付けを解除し、[OK]を押したあと、再び関連付けを設定し直してください。

Ver.1.1.0からBeta 20060731へ

  • ダイアログを微調整
  • ファイル一覧ウィンドウのツリーの最上部に表示されるファイル名をパス付きからファイル名のみに変更
  • ファイル一覧ウィンドウのツリーを最初から展開しておく設定を追加
  • 圧縮時、毎回出力ファイル名を指定する設定を追加
  • 解凍時、「記号」と「数字」を出力フォルダ名から削除する設定を追加
  • 解凍時、圧縮ファイル内にフォルダ・ファイルが一つだけ含まれている場合には、フォルダを作成しない設定を追加
  • 関連付けのLhaForgeのパスを""で括るように変更
  • ファイル一覧ウィンドウのポップアップ情報に、ディレクトリの場合にはその中にあるアイテムの数を表示
  • ファイル一覧ウィンドウで、ファイルサイズをbyte単位で表示する設定を追加
  • 圧縮/解凍それぞれ独立に、同時に処理するファイル数の上限を指定できるようにした
  • 解凍後、「出力フォルダを開く」設定の時、「二重にフォルダを作成しない」設定によりフォルダが作成されなかったときは、出力先フォルダではなく圧縮ファイル中に含まれるフォルダを開くように変更
  • 解凍時、正常に解凍できた圧縮ファイルを削除もしくはごみ箱に移動する設定を追加

Beta 20060329からVer.1.1.0へ

  • 正式版としてコンパイル

Beta 20060328からBeta 20060329へ

  • ファイル一覧ウィンドウで設定画面を開くと、リフレッシュするまではアーカイブ内ファイルの展開/削除が出来なくなっていたのを修正
  • ファイル一覧ウィンドウで逆順でソートした場合に、選択したものと違うファイルが展開/削除されていた問題を修正
  • ファイル一覧ウィンドウでキー入力でのファイル検索を修正

Beta 20060323からBeta 20060328へ

LhaForge本体

  • ファイル一覧からドラッグ&ドロップで解凍するとき、不正なパスのファイルがあると展開に失敗していたのを修正
  • ファイル一覧でファイルが正常に列挙されない形式があったのを修正
  • 動作確認済みDLLバージョンを最新のDLLに限定
  • AISH32.DLLでISHとして正しくないファイルを処理させた場合に異常終了していたのを修正
  • BELのDTVに対応

右クリックメニュー

  • 設定によってはメニューの内容が正常でなくなっていたのを修正

Beta 20060308からBeta 20060323へ

LhaForge本体

  • PMAとBHへの対応を取りやめ
  • 設定画面ではバージョン取得後はDLLを開放するようにした
  • ファイル一覧ウィンドウを最小化したまま終了した際、ウィンドウサイズが正しく保存されない問題を修正
  • Drag&Dropでの解凍を実装
  • XacRett.DLLに対応
  • 圧縮時、出力ファイル名をコマンドラインから指定できるようにした
  • 7z形式の設定でヘッダ圧縮/完全ヘッダ圧縮/ヘッダ暗号化を設定できるようにした
  • ZIP/7zでのマルチボリューム圧縮を行えるようにした
  • 設定画面の関連付けに項目を追加した
  • ish/uueで変換する際フォルダを処理しないようにした
  • LFCaldix.iniにDLLアップデート日時記録を記録するようにした
  • HKIの自己解凍作成に失敗することがあった問題を修正

DLLインストーラ(LFCaldix)

  • 対応DLLを増やした
  • BH32.DLLへの対応を取りやめ

右クリックメニュー

  • 7-Zipの表記を7zにした
  • 「BHで圧縮」を取りやめ
  • 新しい圧縮形式に対応
  • 書庫内ファイル一覧メニューを追加
  • メモリリークを修正

Beta 20060226からBeta 20060308へ

  • ファイル一覧でメッセージ文字列のロードに失敗していたバグを修正
  • BGA32.DLLとAISH32.DLLに対応
  • 圧縮/解凍後、フォルダを開くファイラを指定できるようにした
  • SHIFTキーを押しながら解凍(圧縮/解凍自動判別は除く)でファイル一覧を行うようにした
  • *.bz2/*.gzの圧縮レベルがデフォルトのままになっていたのを修正
  • BEL/ISH/UUENCODEは特定の拡張子を持つファイルのみ解凍対象とするようにした
  • WTLのバージョンを7.5 Finalにした
  • ファイル一覧でタイトルバーにファイル名を表示するようにした
  • ファイル一覧でキー入力による検索を実装
  • ファイル一覧でツリーとリストの同期をとるようにした
  • ファイル一覧でソートを実装
  • ファイル一覧で書庫内ファイル削除を実装(対応形式のみ)
  • ファイル一覧のツールバーのデザインを変更
  • ファイル一覧で書庫内容更新後も元のフォルダにとどまるようにした
  • ファイル一覧でステータスバーにファイル数と使用DLLを表示するようにした
  • ファイル一覧ウィンドウのサイズ/表示設定を保存できるようにした

Beta 20060222からBeta 20060226へ

  • ACE閲覧を可能にした
  • LZH自己解凍ファイル作成時にディレクトリ構造が保存されていなかった問題を修正
  • ファイル一覧でファイル属性を表示/ポップアップで情報表示をするようにした
  • ファイル部分解凍の出力先で「(ドライブ名):\」が「(ドライブ名)__\」に変更されていた問題を修正

Beta 20060114からBeta 20060222へ

LhaForge本体

  • 設定画面を再構成
  • ファイル一覧時のエラーメッセージでファイル名が指定されていなかったのを修正
  • INIにLhaForge自身のバージョンを記録するようにした
  • ファイル一覧時、同一ファイルの同時閲覧を防止するようにした
  • 名前が'-'で始まるファイルがTAR系で圧縮できなかったのを修正
  • ファイル一覧で指定ファイル展開を実装
  • ファイル一覧用ショートカットを作成できるようにした
  • ファイル一覧の高速化
  • ファイル一覧時に一部形式でファイル日時がずれて表示されていたのを修正
  • サイズ優先でコンパイルするようにした
  • IMP形式ファイルの解凍に失敗していたのを修正
  • HKI形式の圧縮/解凍/閲覧に対応
  • BH形式で圧縮する際、明示的に空フォルダを格納しないよう指定するようにした
  • ACEの閲覧を一時的に無効化

DLLインストーラ(LFCaldix)

  • UnAceV2J.dllのインストールがうまくいっていなかったのを修正(ACE形式が解凍できなかった問題が修正される)

Beta 20060106からBeta 20060114へ

  • あらかじめ記録してあるパスワードを使ってパスワード付き圧縮ファイルを作成する機能を削除(パスワードが設定に記録されていれば削除するかどうか聞くようになっている)
  • アーカイブ内ファイルの最終更新日時取得を追加
  • ツールバーをフラットに
  • TABキーで画面のフォーカスを切り替えるようにした
  • ファイルサイズを適当な単位を選んで表示するようにした
  • アーカイブ内ファイルの取得の高速化

Beta 20051211からBeta 20060106へ

  • ファイル実行エラー時にはファイルパスも表示するようにした
  • LhaForgeの設定画面で作成されるショートカットに説明文を設定するようにした
  • 圧縮/解凍のログの改行コード処理の変更
  • ファイルリストウィンドウをまともな物にした。スクリーンショット20060106
  • アーカイバDLLのマイナーバージョンも(もしあれば)取得するようにした
  • アーカイバDLLのバージョンが古い場合には使用しないようにした
  • コマンドラインパラメータの順序に制限が無くなった
  • ファイル構造の解析を少し高速化
  • サイズ優先ではなく速度優先でコンパイルするようにしたのでファイルサイズが大きくなった

Beta 20051130からBeta 20051211へ

  • 破損したアーカイブを扱うときに無限ループに陥っていたかもしれないバグを修正
  • 出力先フォルダを開く設定にしていても、圧縮に失敗したときは出力先フォルダを開かないようにした(解凍失敗時には開く)
  • アーカイブ内一覧機能を追加(LZH/TAR/ZIP/7Z/YZ1/CAB/BHで一応動作確認済み)
  • いくつかの点で高速化&軽量化。ファイルサイズも小さくなった。
  • HKIの解凍に対応。圧縮部分は現在作業中。関連付け/DLL取得も未実装。

1.0.1からBeta 20051130へ

  • .pma(PMarc)と.bel(Belon)の解凍を追加(関連付け/DLL取得は未実装)

1.0から1.0.1へ

  • 「お手軽ショートカット」から圧縮ファイルを指定する際、自己解凍やパスワード付きの指定が無視されていた問題を修正

Final Beta Test2から1.0へ

  • 正式版として公開
  • 右クリック/右ドラッグメニューにアクセスキーをつけた
  • ダイアログにサイズおよび表示方式で若干の修正

Final Beta TestからFinal Beta Test2へ

  • コマンドの処理に若干の修正
  • 「圧縮/解凍後、出力先を開く」ときに名前の似たファイルが開かれることがあった問題を修正
  • インストーラ・アンインストーラ・ヘルプファイルをつけた

Beta-5からFinal Beta Testへ

  • 圧縮先形式を指定した圧縮用ショートカット名を「LhaForgeで<形式名>に圧縮」とした
  • TAR関連ファイルの解凍時の簡易上書き確認を可能にした
  • Ungca/RAR/ACE/IMPの解凍を可能にした
  • メモリリーク修正
  • 圧縮時のファイル指定のエラーメッセージを適切な物にした
  • Jack/BH/YZ1での圧縮・解凍を可能にした(ただしBHは不安定な可能性有り)
  • 対応形式増加に合わせて、メニューの対応形式を増やした
  • 定期的にDLLのアップデートを促すようにした
  • 圧縮解凍自動判別モードをつけた(お手軽ショートカット)
  • 解凍後出力先フォルダを開くをデフォルトにした
  • 7Z自己解凍作成が出来なかったのを修正
  • 設定項目を持たないDLLのバージョンを確認するタブをつけた
  • 全て関連付け/すべて関連付け解除/すべて標準アイコンにする操作を可能にした
  • アイコン種類を増やした
  • アイコンダイアログを修正
  • LFCaldixでダウンロード対象にするDLLリストを見直した
  • 設定ファイルをマルチユーザー対応にした

Beta-4からBeta-5へ

  • ファイルの関連付けを出来るようにした
  • 7z/tarでの圧縮を可能にした
  • SHIFT+右クリック/右ドラッグ、もしくは設定により拡張メニューが表示されるようにした
  • ZIP/7zでパスワード付き書庫が作成できるようにした
  • ZIPで予期しないファイルまで圧縮されていた可能性のある問題を解消
  • LZH/ZIP(BZip2以外)/CAB/7z(BZip2以外)での自己解凍を作成できるようにした
  • DLL自動インストーラ導入
  • Arjの解凍を出来るようにした

Beta-3からBeta-4へ

  • 圧縮および解凍用のショートカットを作成できるようにした
  • 設定ファイルの仕様変更
  • 圧縮/解凍後、フォルダを開くかどうか設定できるようにした
  • 解凍時、二重にフォルダを作成するかどうか設定できるようにした
  • 解凍時、強制的にファイルを上書きするかどうか設定できるようにした
  • CAB/LZH/ZIPの設定を可能にした
  • ZIP形式での圧縮・解凍および7-Zip形式の解凍に対応した

Beta-2.1からBeta-3へ

  • 設定ダイアログ「シェル拡張メニュー」の「圧縮」「解凍」が実際の設定に反映されていなかった問題を修正
  • 解凍機能を実装
  • CAB形式に対応
  • フォルダのみが選択されている場合には「解凍」メニューは表示しないようにした
  • その他、ファイル名の扱いについて修正
  • アイコンデザイン変更
  • ダイアログ設定項目を複数ページに分けた

Beta-2からBeta-2.1へ

  • 既に存在するファイルと同じ名前のアーカイブファイルを作成しようとしたとき、別名で保存しようとするとエラーになっていたバグを修正
  • 一般設定ダイアログのタブオーダーを調整

Beta-1からBeta-2へ

  • 設定ダイアログの実装が進んだ
  • 出力先ディレクトリが存在しない場合の対応を選択できるようにした
  • 出力先のオプションに「出力先を毎回聞く」を入れた
  • C:やD:を丸ごと圧縮する場合にも対応
  • Un???.dllのログ表示に対応
  • 「名前を付けて保存」ダイアログをWindows2000の新しい形式に対応させた(Windows98以前では無効)
  • WinXPスタイルを有効にした(Windows2000以前では無効)
  • 右ドロップ先を出力先として指定できるようにした
  • シェル拡張メニューを調整した
  • ShellMenu.iniの仕様を変更した
  • バージョン情報のURL/メールアドレスをクリック可能なリンクにした

Beta-1

最初期公開版


使い方

LhaForgeでは

  1. エクスプローラ(シェル)の拡張を利用した右クリックメニュー経由
  2. デスクトップや「送る」メニューに作成したショートカット経由
  3. ファイルの関連付けを利用してファイルを一発解凍

の3つの使用方法があります。

また、上級者向けにコマンドラインを用いた操作も提供してあります。


右クリックメニュー

エクスプローラでファイルを右クリックして表示される「LhaForgeで圧縮」「LhaForgeで解凍」「LhaForgeで操作」を使い、ファイルを操作することが出来ます。

また、ファイルを右ドラッグ(ファイルを右クリックしながら別の場所まで移動し、離すこと)したときにも同様のメニューを表示することが出来ます。

一度に大量のファイルを選択して処理するときも、右クリックメニューからなら処理できるファイル数に制限はありません。

フォルダに対し解凍・閲覧・検査を実行した場合、フォルダ内の対応する形式のファイルを自動的に探し出し、処理を行います。

圧縮

たとえば、圧縮の場合、圧縮したいファイルを右クリックし、「LhaForgeで圧縮」メニューをクリックし、その次に圧縮に使用する形式名(たとえばLZH)をクリックすれば圧縮が出来ます。

なお、この圧縮形式の一覧は自由にカスタマイズすることができます。

SHIFTキーを押しながら右クリックで詳細な設定が可能な発展メニューを表示できます。

また、CTRLキーを押しながら圧縮することで個別圧縮を行えます。

解凍

解凍メニューには「通常の場所に解凍」「デスクトップに解凍」「同じ場所に解凍」「指定場所に解凍」があります。

  • 「通常の場所に解凍」…解凍設定で指定された場所に解凍したファイルを出力します
  • 「デスクトップに解凍」…デスクトップに解凍したファイルを出力します
  • 「同じ場所に解凍」…元のファイルと同じ場所に解凍したファイルを出力します
  • 「指定場所に解凍」…解凍したファイルを出力するための場所を指定してから解凍を行います

操作

「LhaForgeで操作」のメニューを使用すれば、「閲覧」で圧縮ファイルの中に含まれるファイルの一覧を表示することができます。また、「検査」では、圧縮ファイルが破損していないかどうか検査することができます。

また、ユーザー定義メニューも「操作」に含まれます。

発展メニュー

SHIFTキーを押しながら右クリックメニューを表示することで、「発展メニュー」を表示することが出来ます。

この発展メニューではパスワード付きファイルや自己解凍ファイルの作成が出来ます。

サブメニュー以下にまとめる

「LhaForgeで～」のメニューをサブメニュー以下にまとめてしまうことができます。


ショートカット

LhaForgeのショートカットにファイルをドラッグ＆ドロップするだけでファイルの圧縮や解凍ができます。LhaForgeのショートカットはLhaForgeの設定画面から作成できます。このショートカットには圧縮専用、解凍専用、圧縮解凍自動判別用、圧縮ファイル内のファイル一覧用、圧縮ファイルの検査用の5種類があります。

また、圧縮専用ショートカットはあらかじめ圧縮対象形式を指定しておくことも、圧縮の際に形式を指定することも出来ます。

作成時に表示されるダイアログで「はい」(あらかじめ決めておく)と答えれば、圧縮形式を指定することが出来ます。


関連付け

LhaForgeには、「関連付け」という機能があります。

関連付けを行えば、圧縮ファイルをダブルクリックするだけで解凍できるようになります。また、特定のキーを押しながら圧縮ファイルをダブルクリックすれば、圧縮ファイルに含まれるファイルの一覧を見ることができます。

関連付けを行うには、設定画面の「関連付け」から設定を行う必要があります。

詳細については「設定」の「関連付け」を参照してください。


ファイル一覧ウィンドウ

LhaForgeでは圧縮ファイルに含まれるファイルの一覧をファイルを解凍することなく表示することができます。また、そのなかから特定のファイルだけを解凍したり、形式によっては特定のファイルだけを削除することができます。

また、形式によっては、閲覧中にファイルをドラッグ&ドロップすれば追加圧縮を行うことが出来ます(同名ファイルは確認なしで上書きされます)。

ファイル一覧を表示するには

ファイル一覧を表示するには、次の3つの方法があります。

  • 圧縮ファイルを選択し右クリックメニューから「LhaForgeで閲覧」を選ぶ
  • 圧縮ファイルを「LhaForgeで閲覧」のショートカットに送る
  • 圧縮ファイルを関連付けしている場合にはSHIFTキー(設定による)を押しながら圧縮ファイルをダブルクリックする

ツールバーの機能

一覧ウィンドウを終了
アーカイブを開く
表示中の圧縮ファイルを全て解凍
表示中の圧縮ファイルを検査
一つ上のフォルダに移動
ファイル一覧を更新
ファイル一覧表示の形式。左から順に、小さいアイコン、大きいアイコン、詳細、一覧
ファイルを検索
選択したファイルを削除。対応形式のみ
選択したファイルを解凍。ドラッグ&ドロップでも可
選択したファイルを一時フォルダに解凍し、関連付けの設定に従って開く。既に一時フォルダにファイルが解凍されていた場合、既存ファイルを開く
選択したファイルを一時フォルダに解凍する。既に一時フォルダにファイルが解凍されていた場合、既存ファイルを上書きする。
選択したファイルを一時フォルダに解凍し、関連付けの設定に従って開く。既に一時フォルダにファイルが解凍されていた場合、既存ファイルを上書きする。
アーカイブにファイルを追加
アーカイブにフォルダを追加
LhaForgeの設定画面を表示

「詳細」の表示内容

表示形式を「詳細」にすると、ファイルの情報を一目で見ることができます。また、一覧の「ファイル名」や「格納パス」の部分をクリックすれば、その項目でファイル一覧を並び替えることができます。同じ部分をクリックすることで、並び替えの種類を「昇順」→「降順」→「並び替え無し」に変えることができます。

使用するDLLによっては、空白や0が表示されることがあります。

ファイル名
格納されているファイルの名前です。
格納パス
圧縮ファイル中での格納ファイルの名前です。
圧縮前サイズ
圧縮前のファイルサイズです。
ファイル種別
ファイルの種類です。
更新日時
ファイルが最後に更新された日時です。
属性
ファイルの属性です。
R
読み取り専用
H
隠し
S
システム
D
フォルダ
A
アーカイブ
圧縮後サイズ
圧縮後のファイルサイズです。
メソッド
圧縮に使用された方式を表示します。
圧縮率
(圧縮後サイズ)/(圧縮前サイズ)の百分率表示です。
CRC
ファイルのチェックサムです。

カラムのカスタマイズ

「格納パス」「圧縮前サイズ」などのカラムを並べ替えたり、表示・非表示を切り替えることができます。

「プログラムで開く」メニュー

選択したファイルを指定したプログラムに送ることが出来ます。メニューにプログラムを追加するには、設定を参照してください。

「送る」メニュー

選択したファイルを指定したプログラムに送ることが出来ます。メニューに表示されるプログラムは、Windowsエクスプローラ上での「送る」メニューから選ばれます(一部項目は非対応)。

「関連付けで開く」について

ファイルをダブルクリックすると、Windowsの関連付けの設定に従ってファイルを開きます。フォルダをダブルクリックした場合には、LhaForge上でフォルダを開きます。

SHIFTキーを押しながら上と同じ操作を行うと、フォルダであっても関連付けに従って開きます。

なお、設定により関連付けで開かない拡張子を指定することができます。


分割圧縮について

LhaForgeではJACK形式による分割とは別に、ZIP形式と7z形式でのファイルの分割圧縮が可能です。

注意点

LhaForgeは圧縮時には出力ファイルの上書きを警告しますが、ZIPや7zの分割圧縮では上書きに確認するファイル名と実際に出力されるファイル名が異なります。

たとえば、「TEST」というファイルをZIPで分割圧縮した場合には出力されるファイル名は「TEST.ZIP.xxx」(xxxは3桁の数字)となりますが、出力先に既に「TEST.ZIP」が存在する場合には既に同名ファイルが存在するとして出力先の指定を求められます。

この動作は現時点では制限事項とさせていただきます。


コマンドライン引数

LhaForgeではコマンドライン引数を利用することでもファイルの操作が可能です。

操作概略

<パラメータ>は必須、[パラメータ]は省略可

/cfg:[ファイル名]
使用する設定ファイルをコマンドラインから指定。処理の関係上、コマンドラインオプションの中で一番最初に指定する必要がある
/b2e
B2E32.dllを使用(圧縮/閲覧/解凍)
/c[:形式]
指定された形式で指定されたファイルを圧縮。/b2eスイッチの後に続けて指定した場合、B2E32.dllを使用して圧縮するようになる
/method[:メソッド]
指定されたメソッドを使って圧縮(B2E32.dll使用時のみ)
/b2esfx
B2E32.dllを使用して自己解凍形式で圧縮(B2E32.dll使用時のみ)
/e
ファイルを解凍
/o:<出力先ディレクトリ>
出力先ディレクトリ指定
/oa
出力先ディレクトリを毎回確認する
/od
デスクトップに出力
/os
入力ファイルと同じフォルダに出力
/l
アーカイブファイルのリスト表示
/f:<ファイル名>
圧縮時出力ファイル名の指定(パス指定は無視される)
/xacrett
XacRett.DLLを強制的に使用(解凍/閲覧)。DLL未導入時はエラー
/!
/xacrettと同等
/m
ファイルを解凍もしくはリスト表示(設定により変更)
/s
ファイル・フォルダを一つずつ圧縮
/t
アーカイブファイルの完全性をテスト(XacRett.dll/B2E32.dll使用不可)
/@<ファイル名>
レスポンスファイル指定。文字コードは特に指定がなければShiftJISを仮定する。
/$<ファイル名>
レスポンスファイル指定。指定されたレスポンスファイルは読み取り完了後削除される
/cp:<文字コード名>
レスポンスファイルの文字コード指定。[文字コード名]と対応する形式は以下の通り。大文字小文字は区別しない。
  • UTF8/UTF-8 : UTF-8(BOMは自動認識)
  • UTF16/UTF-16/UNICODE : UTF-16(エンディアンは自動認識)。BOMがなければUTF16-LEと見なす
  • SJIS/ShiftJIS/S-JIS/S_JIS : ShiftJIS
/delete[:yes|no]
「正常に圧縮されたファイルを削除」の指定。"/delete:yes" or "/delete"で削除、"/delete:no"で残す。この指定は設定より優先される。
/popdir[:yes|no]
「親フォルダを無視して中のファイルだけを圧縮」の指定。"/popdir:yes" or "/popdir"で親フォルダを無視、"/popdir:no"で親フォルダを含め圧縮。この指定は設定より優先される。
/mkdir:<no|always|single>
解凍時フォルダ作成モードの指定。"/mkdir:no"でフォルダを作成しない、"/mkdir:always"で常にフォルダを作成、"/mkdir:single"で二重にはフォルダを作らない。この指定は設定より優先される。
/method:<メソッド>
圧縮メソッド指定。lzh,zip,cab,aishのみ。
/level:<レベル>
圧縮レベル指定。zip,7z,hki,bgaのみ
/priority:<low|lower|normal|high|higher>
プロセス優先度指定
/volume:<サイズ>
分割圧縮時のサイズ指定。ZIP/7zでは「/volume:5m」のように数字+{b,k,m,g}(=Byte,KB,MB,GB)を指定する。JAKではKB単位の数字のみを指定する。ここで指定されるパラメータはDLLにそのまま渡される。zip/7z/jakのみ

圧縮操作時の形式指定

圧縮操作の形式には下のオプションが指定できます(例:「/c:lzh」)。省略すると、ダイアログを表示して圧縮形式を聞いてきます。

指定可能オプションと作成されるファイルの一覧

lzh
LZH
lzhsfx
LZH自己解凍
zip
ZIP
zippass
パスワード付きZIP
zipsfx
ZIP自己解凍
zippasssfx
パスワード付きZIP自己解凍
zipsplit
ZIP分割書庫
zippasssplit
パスワード付きZIP分割書庫
cab
CAB
cabsfx
CAB自己解凍
7z
7z
7zpass
パスワード付き7z
7zsfx
7z自己解凍
7zsplit
7z分割書庫
7zpasssplit
パスワード付き7z分割書庫
tar
TAR
gz
GZip
bz2
BZip2
lzma
LZMA
xz
XZ
tgz
TAR+Gzip
tbz
TAR+BZip2
tlz
TAR+LZMA
txz
TAR+XZ
jak
JACK分割
jaksfx
JACK分割自己解凍
yz1
YZ1
yz1pass
パスワード付きYZ1
yz1sfx
YZ1自己解凍
yz1passsfx
パスワード付きYZ1自己解凍
yz1pubpass
公開鍵方式パスワード付きYZ1
yz1pubpasssfx
公開鍵方式パスワード付きYZ1自己解凍
hki
HKI書庫
hkipass
パスワード付きHKI書庫
hkisfx
自己解凍HKI書庫
bza
BZA書庫
bzasfx
自己解凍BZA書庫
gza
GZA書庫
gzasfx
自己解凍GZA書庫
ish
ISHエンコード
uue
uuencode

圧縮メソッドと圧縮レベル指定

/methodおよび/levelは、/c:[形式]と組み合わせて使用する。存在しないメソッドを指定した場合の動作は不定。

7z形式では、methodの値はそのまま7-Zip32.dllへのコマンドラインで"-m0="の後に渡されるため、複数組み合わせが可能。詳しくは7-Zip32.dll付属文章参照。

lzh
method=lh0,lh1,lh5,lh6,lh7
zip
method=Deflate,BZip2,Deflate64,Copy,PPMd / level=0,1,3,5,7,9
7z
method=LZMA,LZMA2,PPMd,BZip2,Deflate,Copy / level=0,1,3,5,7,9
gza,bza
level=1～9
cab
method=mszip,lzx,plain / lzxのみ、level=15～21
hki
level=0～3
ish
method=s,7,8,n


完全性検査について

LhaForgeでは9つの形式で圧縮ファイルの完全性検査(圧縮ファイル内容が正常かどうかの検査)を行うことができます。

検査できる形式はLZH / CAB / ZIP / 7Z / RAR / HKI / ARJ / ACE / IMP / ISOです。検査の信頼性は、各DLLに依存します。

XacRett.DLL/B2E32.dllを用いた完全性検査はできません。


設定

LhaForgeでは各DLLの性能を最大限引き出せるように、出来るだけ詳細な設定ができるようにしてあります。もちろん、よく分からない場合には設定を変更する必要はありません。初期設定で十分実用に耐える設定になっています。

関連付けとシェル拡張メニュー以外のLhaForgeの設定はユーザー別のiniファイルに保存されます。保存先/全ユーザーで同じ設定を用いる方法は、質問集を参照してください。

注意

Ver.1.0/Ver.1.0.1までは、圧縮時にあらかじめ保存したパスワードを使うことが出来ましたが、Ver.1.1.0以降ではこの設定は廃止されました。

既に設定にパスワードが記録されている場合には設定読み込み時に設定からパスワードを削除するかどうか確認します。


一般設定

設定 - 一般設定

圧縮/解凍のログ

処理結果を表示するタイミングを選ぶことが出来ます。

  • 「エラー時のみ」なら問題が起きたときのみログを表示します。標準設定です。
  • 「毎回表示」なら問題が起きたかどうかにかかわらずログを表示します。
  • 「表示しない」なら問題が起きたとしてもログを表示しません。

出力先の設定

出力先が次の場合、ダイアログを表示する

「ネットワーク」および「リムーバブルディスク」

それぞれについて、圧縮や解凍の出力先がチェックをつけた種類の場合、警告を表示します。

フォルダ作成確認

出力先のフォルダが存在しない場合の対応です。

ファイラ/シェル(上級)

圧縮/解凍時、出力先を開く設定にしていれば、標準ではフォルダを開くのにWindowsのエクスプローラを使います。しかし、ここで設定を行えば好きなファイラを使うことができます。

上の欄にはファイラ本体のパスを設定します。「引数」の欄には、ファイラに渡すコマンドライン引数を設定します。このとき、LhaForgeは下記の識別子を対応する情報に置き換えます。

「ファイラ/シェル(上級)」の設定で参照できる情報

以下に示す参照名は、全て大文字小文字を区別します。

システムの環境変数
%WINDIR%のように変数名を%で挟んで書きます。変数名は全て大文字で書く必要があります。
出力先フォルダ
表記:{dir},{OutputDir}、値:「C:\Output\」など
出力先ドライブ
表記:{OutputDrive}、値:「C:」など
圧縮先ファイル名
表記:{OutputFileName}、値:「archive.zip」など
圧縮先ファイル名(フルパス)
表記:{OutputFile}、値:「C:\Output\archive.zip」など
LhaForge本体のファイル名
表記:{ProgramFileName}、値:「LhaForge.exe」など
LhaForge本体のファイル名(フルパス)
表記:{ProgramPath}、値:「D:\bin\LhaForge.exe」など
LhaForge本体の入ったフォルダ
表記:{ProgramDir}、値:「D:\bin」など
LhaForge本体の入ったドライブ
表記:{ProgramDrive}、値:「D:」など

引数の例

コマンドライン引数に「-l<フォルダパス>」で指定したフォルダパスを開くタイプのファイラにコマンドラインを渡すのであれば、「-l{dir}」を引数に設定します。

処理完了をシェルに通知する

処理完了後、エクスプローラなどのファイル表示を更新させます。圧縮/解凍後、作成されたファイルをエクスプローラに表示させるために、手動での表示更新が必要となる環境で使用します。

プロセス優先度

圧縮/解凍等の処理の優先度を変更します。LhaForgeの優先度を下げておくと、圧縮しながらでも他の作業が快適に行える場合があります。

一時フォルダ設定

圧縮・解凍時に使用される一時フォルダを指定します。使用するDLLや処理内容によっては効果がない場合があります。


右クリックメニュー

設定 - 右クリックメニュー

右クリック/右ドラッグメニューを有効にする

ここにチェックを入れれば、シェル拡張(右クリック/右ドラッグメニュー)が有効になり、エクスプローラでファイルを右クリックしたときに表示されるメニューに「LhaForgeで圧縮」「LhaForgeで解凍」「LhaForgeで操作」等が追加されます。

ここにチェックを入れて、シェル拡張を有効にしておくことをおすすめします。

常に発展メニューを使用する

ここにチェックを入れれば、「LhaForgeで圧縮」のメニューが常に詳細なものとなります。この詳細なメニューはSHIFTキーを押しながら右クリックしたときに表示されるものと同じで、パスワード付きファイルや自己解凍ファイルの作成が指示できます。

圧縮メニューをカスタマイズする

ここにチェックを入れれば、メニューに表示する内容をカスタマイズできます。

「圧縮」「解凍」「閲覧」/「ここに圧縮」「ここに解凍」

メニューにそれぞれの項目を表示させるかどうかを選択できます。

サブメニュー以下にまとめる

LhaForgeが表示するメニューを、「LhaForge」メニュー以下にまとめて表示します。

メニューのカスタマイズについて

「圧縮メニューのカスタマイズ」は、右クリック時の「圧縮」に表示されるメニュー項目を編集するものです。

「ユーザー定義メニュー」は、右クリック時のメニューにメニューを追加するものです。ユーザー定義メニューは、WindowsXP以降なら「LhaForgeで操作」メニュー以下、Windows2000以前なら右クリックメニューに直接追加されます。

ユーザー定義メニューの定義

「キャプション」にはメニューに表示される文字列を入力します。&に続けて半角文字を書くとアンダーバー付きで表示され、ショートカットキーになります。&&と続けて書けば&がそのまま表示されます。

「パラメータ」にはコマンドラインパラメータをそのまま書きます。ファイル名や出力先はこのコマンドラインに続けて自動で追加されます。コマンドラインの詳細は該当項目を参照してください。


ショートカット

設定 - ショートカット

ドラッグ&ドロップでファイルを圧縮/解凍/閲覧/圧縮解凍自動判別/閲覧/完全性検査が出来るショートカットを作成できます。

使い方

  • デスクトップに作成したショートカットなら、処理したいファイルをまとめてショートカットにドラッグ&ドロップする
  • 「送る」メニューに作成したショートカットなら、処理したいファイルを選んで右クリックし、表示されたメニューから「送る」→「LhaForgeで～」をクリックする


ファイル一覧ウィンドウ

設定 - ファイル一覧ウィンドウ

ウィンドウ関連

サイズ/表示設定を保存

ONのとき、ウィンドウのサイズと表示のソートの設定が保存されます。この設定がOFFのときは、毎回標準の表示スタイルになります。

ウィンドウの位置を保存

ONのとき、ウィンドウの位置が保存されます。複数ウィンドウを開いた時にも同じ位置で重なって表示されることに注意してください。

無意味なパスを無視

ファイル名/フォルダ名として意味のないものを無視します。

ファイルサイズをバイト単位表記

「元サイズ」の欄をキロバイトなどを使わず全てバイト単位で表記します。

初めからツリーを展開

ファイル一覧ウィンドウ右側のフォルダツリーを初めから展開した状態で表示します。

ESCキーで終了

ONのとき、ファイル一覧ウィンドウがアクティブなときにエスケープキーを押すことでウィンドウを閉じます。

タブ機能を無効化

タブによるファイル一覧を無効化します。この設定が有効な場合、「全て単一ウィンドウで開く」は使用できません。

全て単一ウィンドウで開く

ファイル一覧を全て一つのウィンドウ内にタブとしてまとめて表示します。

格納パスにファイル名を表示しない

ONのとき格納パス中のファイル名部分を表示しなくなります。

一時フォルダの整理

関連付けで開く際、LhaForgeは一時フォルダにファイルを展開します。展開されたファイルは通常はLhaForgeの終了時に削除されますが、何らかの原因で削除できなかった場合に残ってしまったファイルがあるとき、このボタンを使うことで削除することができます。

表示方法

この設定はファイル一覧表示中にもF6/F7/F8キーで切り替えできます。

フォルダ階層表示

通常の表示方法です。

階層構造を無視

ファイルの一覧をフォルダ構造を無視して表示します。フォルダ構造を解析しない分若干高速です。

階層を無視しファイルのみを表示

ファイルのみを確認したい場合に使用します。

「関連付けで開く」

ファイル一覧ウィンドウで「関連付けで開く」を許可する拡張子と拒否する拡張子を設定します。拒否に設定された拡張子を持つファイルは、「関連付けで開く」が無視されます。安全のために、「実行可能なら全て拒否」はなるべく有効にしてください。

この設定には、*や?といったワイルドカードが使用できます。「関連付けで開く」を完全に無効化したい場合には、「拒否」に「.*」とだけ書いてください。

標準では、以下の拡張子を拒否するようになっています。

.bat;.class;.cmd;.com;.dll;.exe;.lnk;.pif;.scr;.sys;.wsh;.vbs;.vbe;.js;.jse;.folder;.reg;.inf;.scf;.url;.eml;.bin;.wsf;.wsh

プログラムの登録

ファイル一覧ウィンドウでファイルを右クリックした時にでるメニュー「プログラムで開く」に表示するプログラムを登録できます。

処理対象のファイル名(単一)
表記:%S、複数のファイルを一度に処理する場合には、各ファイル毎に呼び出されます。
スペースで区切られた処理対象のファイル名のリスト
%F

これらの他、「出力先を開くファイラ」の設定と共通の設定が利用可能です。

ツールバー

カスタム画像

ツールバーに使用する画像を差し替えることができます。標準では、内蔵の画像が使われています。画像は幅456ピクセル×高さ24ピクセルのビットマップです。左上のピクセルの色が透過色として使用されます。標準のツールバー画像:

ツールバーを表示

ツールバーを表示させないようにすることができます。


圧縮共通設定

設定 - 圧縮共通設定

出力ファイル名を毎回指定

出力場所ではなく出力ファイル名を毎回指定することができます。

同時に圧縮するファイル数を制限する

処理負荷を集中させないために同時に圧縮するファイル数を制限します。

可能ならフォルダより下のファイルを圧縮

圧縮対象がフォルダ一つだけの場合、その中身だけを圧縮します。

形式省略時の指定

形式名を指定せずに圧縮した場合(お手軽ショートカットから圧縮を指示した場合など)に使用するデフォルト圧縮形式です。設定がない場合は形式選択ダイアログを表示します。

正常に圧縮されたファイルを削除

正常に圧縮が完了したファイルを削除もしくはごみ箱へ移動します。ただし、AISH32.DLL / JACK32.DLL / B2E32.DLLを使用した際には、正常に圧縮されたかどうか確認できないため、「圧縮失敗を検知できない場合も削除」がONでない限り削除は行われません。


解凍共通設定

設定 - 解凍共通設定

ファイルを確認せずに上書きする

ファイルを解凍する際、出力先に既に同名ファイルが存在するとき、このチェックを入れるとユーザーに問い合わせることなくファイルを上書き解凍します。

BELファイルを解凍する際にはこの設定にかかわらず必ず上書き確認が行われ、ish/UUENCODEファイルの復号時には既に同じ名前のファイルが存在すれば、新しく解凍されるファイルの先頭には2桁の数字がつきます。B2E32.DLL使用時については、使用するプログラムに依存します。

同時に解凍するファイル数を制限する

処理負荷を集中させないため、同時に解凍するファイル数を制限します。

正常に解凍された圧縮ファイルを削除

正常に解凍が完了したファイルを削除もしくはごみ箱へ移動します。ただし、AISH32.DLL / JACK32.DLL / XacRett.DLL / B2E32.DLLを使用した際には、正常に解凍されたかどうか確認できないため、「解凍失敗を検知できない場合も削除」がONでない限り削除は行われません。

RARのpartファイルを削除

分割RARファイルを解凍した後、連番のpartファイルも削除します。

パスワード入力回数を最小にする

「ファイル名も暗号化されたRAR書庫」を扱う際、パスワードを1回入力するだけで展開できるようになります。ただし、「ファイル名も暗号化されたRAR書庫」の展開時には、二重フォルダ判別は無効になり、常にフォルダを作るようになります。

解凍しない拡張子

指定された拡張子のファイルは圧縮ファイルとは見なさず、解凍しません。標準では、Office 2007以降のドキュメントファイル(実体はZIPファイル)を解凍しないように設定されています。

フォルダ作成の設定

フォルダ名末尾の数字と記号を取り除く

この設定は「常にフォルダを作成して～」「二重にはフォルダを作らない」のときのみ有効です。圧縮ファイル名と同じ名前のフォルダを作る時、名前の最後に記号か数字が含まれていればそれを削除します。

圧縮ファイルに含まれるフォルダはこの処理の対象ではありません。

ファイル・フォルダが一つだけの時フォルダを作らない

圧縮ファイル中に含まれるファイルやフォルダの総数が1つだけの時、フォルダ作成の設定にかかわらずフォルダを作成しません。

フォルダ作成の設定

常にフォルダを作成して、その中に解凍する
ファイルを解凍する際、圧縮ファイル名と同じ名前のフォルダを作成し、その中にファイルを解凍します。
二重にはフォルダを作らない
ファイルを解凍する際、圧縮ファイル中にフォルダが含まれていれば、「常にフォルダを作成して、その中に解凍する」場合には二重にフォルダが作成されることがあります。「二重にはフォルダを作らない」にしておけば、フォルダが二重になるときには、圧縮ファイル名と同じ名前のフォルダを作成せず、圧縮ファイル中に含まれるフォルダに入った状態でファイルを解凍します。フォルダが二重にならないときには、「常にフォルダを作成して、その中に解凍する」と同じ動作をします。
フォルダを作成しない
圧縮ファイルの中身がそのまま出力先に解凍されます。

「Test」という圧縮ファイル中にfolder1というフォルダとfile1,file2の2ファイルが含まれるとき

フォルダ「folder1」にfile1,file2の2ファイルが含まれた状態で「Test」という圧縮ファイル中に格納されているとき


設定 - 関連付け

関連付けを行えば、圧縮ファイルをダブルクリックするだけでLhaForgeでファイルを解凍できるようになります。また、SHIFTキーを押しながら圧縮ファイルをダブルクリックすれば圧縮ファイルの中身の一覧を見ることができるようになります。

関連付け

関連付け作成

基本的には「全てチェックする」を押した後「アイコンを全て標準に」もしくは「全て標準単一アイコンに」を押し、「OK」を押して設定を反映させれば関連付けが完了します。ただし、関連づけを行わない方がよい拡張子(*印付きの物)については、標準では関連づけしません。

関連付け解除

解除したい形式のチェックを外すか、もしくは「全てチェック解除」を押せば関連付けが解除され、以前の状態に戻ります。

関連付け修復

関連付けのチェックが付いていれば、[OK]ボタンを押した時点でLhaForgeは関連付け設定を自分の物に書き換えます。関連付け設定が壊れてしまった場合でもOKボタンを押すだけで修復できます。

関連付けのアイコン

外部アイコンファイルの並び順は、以下の通りです。

  1. lzh
  2. zip
  3. jar
  4. cab
  5. 7z
  6. rar
  7. gca
  8. .tar関連
  9. .deb/.rpm
  10. lib
  11. jak
  12. hki
  13. yz1
  14. ace
  15. arj
  16. bza
  17. gza
  18. imp
  19. ish
  20. uue
  21. bel
  22. 単一アイコン用
  23. lzs
  24. lha
  25. tar
  26. gz
  27. tgz
  28. bz2
  29. tbz
  30. z
  31. taz
  32. cpio
  33. a
  34. rpm
  35. deb
  36. iso
  37. xz
  38. txz
  39. lzma
  40. tlz


開く動作

設定 - 開く動作

圧縮ファイルを開く時、特定のキーを押しているかどうかにより動作を選択できます。


DLLの情報と更新

設定 - DLLの情報と更新

LhaForgeで使用するアーカイバDLLを導入・更新することができます(インターネット接続環境が必要です)。機能面だけでなく安全面からもできるだけ最新版のDLLを使うようにしてください。

表示の意味

DLLバージョンはLhaForgeが内部的に取得した情報ですので、DLL付属の文章に記載されているバージョンとは表記が異なる場合があります。

DLLが見つからない場合、もしくはDLLがある程度より古い場合には「利用不可」と表示します。もしDLLが利用不能な場合、最新版に更新する事で改善する場合があります。

定期的にアップデートを促す

LhaForgeが起動されるタイミングで、最後のアップデート通知から指定された日数を過ぎていた場合、更新を確認するように促してきます。

このアップデートプログラムはK.INABAさんの作られた「caldix1.19」をベースに作成しました。

全自動インストール

DLLの更新において、最低限の確認しか行いません。更新後の表示も極力抑制されます。

XacRett.DLL/B2E32.dllについて

XacRett.DLL/B2E32.dllは多彩な形式のファイルの解凍に対応したDLLですが、自動DLLインストーラがインストール/更新することはありません。詳細については、設定の各項目を参照してください。


LZH設定

設定 - LZH設定

圧縮形式の選択

通常は「lh5形式」を使用してください。lh6/lh7についてはテスト版扱いであり、この形式のファイルの公開は禁止されています。

自己解凍形式について

設定の詳細についてはUnlha32.dllの付属文書を参照してください。


ZIP設定

設定 - ZIP設定

圧縮形式の選択

ZIP形式でファイルを圧縮する際に使用する圧縮方式を選択します。

基本的には設定の説明通りです。標準は「Deflate方式」です。

圧縮レベル

ファイルを圧縮する際の圧縮レベルを選択できます。

Deflateエンコーダの上級設定

7-Zip32.dll付属の文章を参照してください。

常にUTF-8でファイル名を格納する

異なる環境でファイルを展開した際のファイル名の文字化けを軽減するオプションです。ただし、解凍できない環境が多々あります。

パスワード設定時の暗号化手法

パスワード設定時のファイル内容暗号化オプションです。AES256がもっとも強力ですが、対応ソフトが限られています。ZipCryptoはAESよりも暗号強度は弱いものの、ほとんどのソフトで解凍が可能です。

分割サイズ

有効にすると、分割解凍時の分割サイズをここで指定した値とします。無効にすると、分割サイズをその都度確認します。

パスワードについて

Ver.1.0/Ver.1.0.1までは、圧縮時にあらかじめ保存したパスワードを使うことが出来ましたが、Ver.1.1.0からはこの設定は廃止されました。


CAB設定

設定 - CAB設定

圧縮形式の選択

MSZIP形式/LZX形式/無圧縮から選択できます。標準は「MSZIP形式」です。


7z設定

設定 - 7z設定

圧縮方式

7z形式でファイルを圧縮する際に使用する圧縮方式を選択します。

標準は「プリセットを使う」です。プリセット圧縮ではLZMA方式が使われます。

プリセット圧縮を使用しない設定でPPMd方式を使用すれば、テキストファイルに対する圧縮率が良くなります。

プリセット圧縮レベル

ファイルをプリセット圧縮を使用して圧縮する際の圧縮レベルを選択できます。

「プリセット圧縮」+「標準圧縮」は「LZMA方式」+「標準」の設定と基本的には同じですが、「プリセット圧縮」+「標準圧縮」は実行ファイルに対して特別な処理を行うので、圧縮が良くなります。

LZMAのモード

LZMA方式で圧縮を行う場合の圧縮レベルを指定できます。同じLZMA方式でもプリセット圧縮を行う場合には隣の「プリセット圧縮レベル」で設定してください。

PPMdのモデルサイズ

7-Zip32.dll付属の文章を参照してください。

圧縮オプション

ソリッド圧縮を行う

一度ファイルを無圧縮で結合した後、圧縮する処理です。通常、ソリッド圧縮を行うと圧縮率が良くなります。

ヘッダ圧縮を行う/全てのヘッダを圧縮

ONにすると圧縮率が上がります。

ヘッダ暗号化

パスワードによる暗号化を行う際、ヘッダも暗号化するかどうかを選択できます。標準はOFFです。

分割サイズ

有効にすると、分割解凍時の分割サイズをここで指定した値とします。無効にすると、分割サイズをその都度確認します。

パスワードについて

Ver.1.0/Ver.1.0.1までは、圧縮時にあらかじめ保存したパスワードを使うことが出来ましたが、Ver.1.1.0からはこの設定は廃止されました。


TAR系列

設定 - TAR/GZ/BZ2/XZ/LZMA設定

圧縮レベルの選択

圧縮レベルを選択します。標準では全て9です。

展開時、ファイル名文字コード変換を行う

ファイル名がShift_JIS以外で作成されたアーカイブについて、文字コード変換を行います。文字化けが発生した場合は、このオプションをオフにする事で改善される場合があります。

各形式について

TAR形式は複数のファイルをまとめる為のもので、単体では圧縮能力はありません。一方、GZ/BZ2/XZ/LZMAは単一のファイルを圧縮することは出来ますが、複数のファイルを圧縮することは出来ません。通常は、TARでファイルをひとつのファイルにまとめて、GZ/BZ2/XZ/LZMAで圧縮します。

GZは特にUNIX環境において標準的な圧縮方法です。BZ2はGZよりも圧縮率が高い反面、処理速度は低速です。

XZ/LZMAは7z形式と同様のアルゴリズムを使用した方式です。従来の形式よりもさらに圧縮率が高いことが多いですが、処理速度はさらに低速です。また、LZMAは規格が古いため、代わりにXZを使用してください。


JACK設定

設定 - JACK設定

分割サイズの指定

ファイル分割サイズはキロバイト単位で指定します。1.44MBであれば1423KBを指定します。


HKI設定

設定 - HKI設定

圧縮レベル/暗号化アルゴリズム

基本的には表記の通りです。暗号設定については、UNHKI32.DLL付属ドキュメントを参照してください。


BZA/GZA設定

設定 - BZA/GZA設定

圧縮レベル

BZA/GZA共に、圧縮レベルを1から9の間で設定する事ができます。レベル9が最高圧縮となります。標準はいずれも9です。


ISH/uuencode設定

設定 - ISH/uuencode設定

ISH変換時のフォーマット

ISHで変換に使う文字種を設定します。

uuencodeの設定

uuencode変換時、拡張フォーマットとして出力にチェックサム情報も付加します。このチェックサムはデータ上で計算したものになります。


XacRett設定

設定 - XacRett設定

XacRett.DLLはXacRettというツールを元にした統合アーカイバDLL仕様のDLLです。XacRettは、他の統合アーカイバDLLやDOS用のexe等の外部モジュールを利用せずに対応形式をひたすら増やすこと[だけ]を目的に作られた解凍専用のツールです。

対応形式は多彩なのですが、XacRett/XacRett.DLLは共に、「このソフトは、安全性や操作性や機能や速度の面の改善はそっちのけで製作しています。永遠にβ版です。何が起きても対処できる自信がない人は、お遊びのサブアーカイバとして以外は使用しないこと。 」と注意書きをしてありますので、LhaForgeではXacRett.DLLを有効にするよう設定しない限り使用しないようにしてあります。

XacRett.DLLを有効にする

有効にすると、LhaForgeはXacRett.DLLを使用するようになります。

XacRett.DLLを優先させる拡張子

XacRett.DLLを有効にするだけでは、LhaForgeはXacRett.DLL以外のDLLでの解凍を試みた後、一番最後にXacRett.DLLでの解凍を試みます。

この設定で拡張子を指定すれば、その拡張子で優先的にXacRett.DLLを使用するようになります。

拡張子を指定する場合、拡張子は「.(ドット)」ではじめ、「;(セミコロン)」で区切ってください。

例:「.lzh;.bel」

シェル拡張メニューに組み込む

右クリック/右ドラッグメニューにXacRett.DLLでファイルを処理するためのメニューを追加します。このメニューを使用した場合、「XacRett.DLLを有効にする」の設定に関わらずXacRett.DLLだけを使用してファイルを処理するようになり、XacRett.DLL以外は使用しようとはしません。


B2E設定

設定 - B2E設定

B2Eスクリプトは、K.INABA氏作のアーカイバ「Noah」で使用されていた機能拡張スクリプトで、必要な外部プログラムを組み合わせることで、任意の形式について圧縮・解凍などを行えるようになります。

B2Eスクリプトの場所

B2Eスクリプトが保存されている場所を指定することが出来ます。NoahのB2Eスクリプトフォルダを指定し共存させることもできます。ここが空白の場合、B2E32.dllと同じフォルダ内のB2Eフォルダが使用されます。

なお、B2E32.dll独自の拡張として、B2Eフォルダに必要な外部プログラムを入れておくとPATHを設定しなくてもそのプログラムを使用するようになります。

B2E32.dllを通常の解凍に有効にする

有効にすると、LhaForgeはB2E32.dllを解凍に使用するようになります。標準では無効です。

B2E32.DLLをXacRett.DLLより優先させる

B2E32.dllを有効にするだけでは、LhaForgeはB2E32.dll/XacRett.DLL以外のDLLでの解凍を試みた後、XacRett.DLLでの解凍を試み、それでも解凍できない時のみB2E32.dllで解凍を試みます。

B2E32.dllを優先させるようにすれば、B2E32.dllとXacRett.DLLの優先順位を逆転させます。

シェル拡張メニューに組み込む

右クリック/右ドラッグメニューにB2E32.dllでファイルを処理するためのメニューを追加します。このメニューを使用した場合、「B2E32.dllを通常の解凍に使用する」の設定に関わらずB2E32.dllだけを使用してファイルを処理するようになります。

圧縮メニュー

「シェル拡張メニューに組み込む」が有効な場合、圧縮メニューを生成すれば「LhaForge+B2E32.dll」メニューに「形式を選択して圧縮」メニューが追加され、B2Eを使用した圧縮でも右クリックメニューから形式を選択できるようになります。

圧縮メニューはインストールされているB2Eスクリプトのうち有効なものについて生成されます。

B2E32.dllを優先させる拡張子

この設定で拡張子を指定すれば、その拡張子を持つファイルを解凍する時B2E32.dllを通常のDLLより優先して使用するようになります。ただし、XacRett.DLLとの優先順位は設定に従います。

拡張子を指定する場合、拡張子は「.(ドット)」ではじめ、「;(セミコロン)」で区切ってください。

例:「.lzh;.bel」


DLLの有効/無効

設定 - DLLの有効/無効

指定したDLLのみを使用します。環境との相性が悪い等の理由で特定のDLLを使用したくない場合、該当DLLのチェックを外してください。

なお、XacRett.DLLおよびB2E32.dllについては、それぞれの設定から有効/無効を設定してください。


アンインストール

アンインストール手順を説明します。以下の画面はVer.1.1.0の時の物ですが、基本的にバージョンと日付が違う以外は全て同じです。

「スタート」メニューから、コントロールパネルを開きます。

「コントロールパネル」から、「アプリケーションの追加と削除」(もしくは「プログラムの追加と削除」)を選択します。

「プログラムの変更と削除」から「LhaForge ???」(???はバージョンによって変わります)を探してください。ここで見つからなければLhaForgeはインストールされていないということになりますので、アンインストールを続ける必要はありません。

LhaForgeが見つかったら、LhaForgeを選択し、「変更と削除」(もしくは「追加と削除」)ボタンを押してください。「LhaForgeのアンインストールを開始しますか？」と聞かれるので、「はい」を押してください。

すると、次のような画面が現れます。

ここで「はい」を押せば、ファイルの関連付けが解除されます。「いいえ」を押せば、アンインストール後もファイルの関連付けが残ります。バージョンアップの前には関連付けを解除しないことをおすすめします。

ここで関連付けが解除されると、関連付けはLhaForgeをインストールする前の設定に戻ります(もし、LhaForgeをインストールする前に関連付けされていたプログラムがアンインストールされていた場合には関連付けは無くなります)。

LhaForgeをアンインストールしても、「デスクトップ」と「送る」メニューに作成したショートカットは残るので、手動で削除する必要があります。

ここで「はい」を押せば、「送る」フォルダが開きます。必要なら、LhaForgeのショートカットを削除してください。

関連付けと右クリックメニューを解除すれば、次はファイルの削除に移ります。出てきたメッセージボックスに「はい」と答えれば、ファイルの削除が実行されます。

もし、この後再起動を求められた場合は指示に従って再起動してください。

これでアンインストールは完了です。が、LhaForgeがインストールされていたフォルダ内には設定ファイルが削除されずに残ります。必要であれば手動で削除してください。


バージョンアップ

LhaForgeをバージョンアップするには、二種類の方法があります。

方法1.

いったん古いLhaForgeをアンインストールしてから新しいLhaForgeをインストールしてください。

方法2.

  1. LhaForgeで右クリックメニューを無効にする
  2. Windowsを再起動する
  3. LhaForgeを上書きインストールする
  4. 右クリックメニューを有効にする


質問集

RARファイルがうまく解凍できない

他言語ファイル名のファイルや新形式ファイルが解凍できない場合があります。こちらのunrar32.dllを使用してみてください。

シェル拡張がうまく動かない

設定から「シェル拡張を有効にする」を選んでみたのですが、「'ShellExtDLL.DLL'がロードできません」と出ます。
LhaForgeをもう一度インストールし直してください。上書きインストールでかまいません。
右クリックメニューからファイルを処理しようとしましたが、「ファイルが見つからない」と出ます。
LhaForgeの設定からシェル拡張を解除してください。Windowsを再起動したら、もう一度LhaForgeの設定からシェル拡張を有効にしてみてください。

どちらも、エクスプローラの右クリックメニューを拡張するためのDLLがLhaForgeと同じフォルダにないのがエラーの原因です。

LhaForgeの設定はどこに保存されていますか?

LhaForgeの設定は、関連付けとシェル拡張メニューの有効/無効はレジストリに保存されます。それ以外の設定はLhaForge.ini(LhaForge本体の設定)およびLFCaldix.ini(DLLインストーラの設定)に保存され、以下の順で検索されます。

  1. 「Windowsの共通プロファイルフォルダ\LhaForge」。LhaForge.iniがあれば全ユーザーで共通の設定となります。ユーザー自身がファイルを作成した場合のみ参照されます。LFCaldix.iniはここに作成され、最終アップデート日時を記録します。
  2. 「LhaForge本体と同じフォルダ」。全ユーザーで共通の設定となります。ユーザー自身がファイルを作成した場合のみ参照されます。
  3. 「LhaForge本体のフォルダ\ユーザー名」。互換性のために残されています。LhaForgeが新規にファイルを作成することはありません。
  4. 「Windowsのユーザープロファイルフォルダ\AppData\Roaming\LhaForge」。この場所が標準です。

アーカイブ内ファイル一覧に表示されないフォルダがある

CABやYZ1等では圧縮時に空フォルダを格納できないため、空フォルダは圧縮ファイルに含まれません。

また、一部のDLLでは空フォルダを列挙できないことがあります。

XacRett.DLLとは?どこで入手できる?

XacRett.DLLはXacRettというツールを元にした統合アーカイバDLL仕様のDLLです。XacRettは、他の統合アーカイバDLLやDOS用のexe等の外部モジュールを利用せずに対応形式をひたすら増やすこと[だけ]を目的に作られた解凍専用のツールです。

LhaForgeで使用できるXacRett.DLLはBontyさんの作品で、Bontyさんのページである「Bonty's HomePage(http://hp.vector.co.jp/authors/VA030681/)」から入手できます。

元のツールであるXacRettはk.inabaさんの作品で、k.inabaさんのページである「kMonos.NET(http://www.kmonos.net/)」から入手できます。

XacRett/XacRett.DLLは、「このソフトは、安全性や操作性や機能や速度の面の改善はそっちのけで製作しています。永遠にβ版です。何が起きても対処できる自信がない人は、お遊びのサブアーカイバとして以外は使用しないこと。」と注意書きがされています。

XacRett.DLL付属の文章をよく読んだ上で使用してください。XacRett.DLLをLhaForgeから使用する際には、「設定」の「XacRett.DLL」の項目を参照してください。

LhaForgeで解凍できないZIPファイルがあります。他のツールでは解凍できました。

DLLが対応していないタイプのZIPファイルである可能性があります。UNZIP32.DLLを使う他のツールで解凍してみる、もしくはXacRett.DLLで解凍してみてください。

一口にZIPファイルといっても、実は圧縮方式などによりいくつか種類があります。

LhaForgeでは、ZIPファイルの解凍には7-Zip32.dllおよびUnHki32.dllを使用します。しかし、この2つのDLLは現在の所出回っているZIPファイルのうちいくつか解凍できない種類の物があるそうです。

UNZIP32.DLLを使う解凍ソフトで解凍できたのであれば、上の2つのDLLが対応していないファイルであったのでしょう。

他のツールを使わずにLhaForgeだけで解凍したいときには、XacRett.DLLを使うと解凍できる可能性があります。

InstallShield形式のCABファイルを解凍したい

XacRett.DLLでの解凍を試してみてください。

パスワード付きでファイルを圧縮する方法は？

右クリックメニューから

SHIFTキーを押しながらファイルを右クリックし、発展メニューを呼び出してください。右クリックメニューを有効にしていれば、パスワード付きの項目が出来ているはずです。

圧縮ショートカットから

圧縮形式の選択で「パスワード付き」にチェックを入れて、圧縮したい形式のボタンを押してください。

「LhaForgeで検査」でXacRettの設定が無視されています

XacRett.DLLではファイルの検査を行うことが出来ないので、「優先する拡張子」の設定も無視されます。

ファイル一覧ウィンドウの「ファイル名」カラムが消えちまった！

メニューから、「表示(V)」→「表示項目のカスタマイズ(C)」→「リセット(R)」で元通り。

ファイル一覧ウィンドウからフォルダを"関連付けで開く"と、拒否する設定になっている拡張子を持つファイルも展開された

フォルダを"関連付けで開く"場合、フォルダ(とその中身)を全部解凍しています。そのときはフォルダの中身の拡張子を検査してはいませんので、このような動作となります。


連絡先

作者への連絡方法

  • Webページ:「泥巣」http://claybird.sakura.ne.jp/上の掲示板を利用して
  • メール:claybird.without.wing@gmail.comに直接メール

のいずれかの方法で作者(Claybird)に連絡を取ることが出来ます。